Interface shows down in GUI but active in ifconfig.


  • Hello,

    I recently updated my pfsense install to Version 2.4.5 -RELEASE. With this instance comes support for Mellanox Connectx-3 VPI cards configured in Ethernet mode. Correspondingly I added a Connectx-3 card to my setup.

    The install seems to have gone fine and I can see that interface in the GUI (and through the shell). However, the mlxen0 interface shows as 'Down' (red inverted arrow) in the GUI but is showing as active in the ifconfig :

    [2.4.5-RELEASE][root@gateway.myhost]/root: ifconfig mlxen0
    mlxen0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 9000
    options=ed00bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWFILTER,VLAN_HWTSO,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
    ether xx:xx:xx:xx:b2:a4
    hwaddr xx:xx:xx:xx:b2:a4
    ether xx:xx:xx:xx:b2:a4
    hwaddr xx:xx:xx:xx:b2:a4
    inet6 xxxx::xxxx:xxx:xxxx:b2a4%mlxen0 prefixlen 64 scopeid 0x8
    inet 192.168.10.1 netmask 0xffffff00 broadcast 192.168.10.255
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect (40Gbase-CR4 <full-duplex,rxpause,txpause>)
    status: active

    Running dmesg give the following output :

    calcru: runtime went backwards from 107207102 usec to 105690732 usec for pid 12 (intr)
    calcru: runtime went backwards from 88963624 usec to 87941588 usec for pid 11 (idle)
    calcru: runtime went backwards from 10265 usec to 10161 usec for pid 1 (init)
    calcru: runtime went backwards from 13996 usec to 13794 usec for pid 0 (kernel)
    mlxen0: link state changed to DOWN
    mlxen0: link state changed to UP

    Can someone please help me with getting this interface up in pfsense? The NIC port is connected to an MLNX6036 switch to a port (on the switch) that is configured in ETH mode. I have confirmed that the NIC itself is also configured in ETH mode.

    Thanks in advance.