Status / DHCP Leases - Action Column disappeared after creating static ip addresses



  • I have about 50 devices, and I created 14 static IP addresses above 192.168.1.100.
    After creating the 14th static address, I noticed that when I look at the Status / DHCP Leases page, all of the data appears normally.

    BUT:

    The Actions column is now missing.
    I have rebooted pfsense
    I have tried a different browser
    Yes, I have tried re-scaling windows.

    Obviously I know that the Actions column is supposed to be there, but the last column now displayed on multiple browsers is the Lease Type.

    Configuration
    Version 2.4.5-RELEASE (amd64)
    built on Tue Mar 24 15:25:50

    Browsers tried: Chrome, Firefox

    System platform

    CPU Type Intel(R) Core(TM) i5-4440 CPU @ 3.10GHz
    Current: 3100 MHz, Max: 3101 MHz
    4 CPUs: 1 package(s) x 4 core(s)
    AES-NI CPU Crypto: Yes (active)
    Hardware crypto AES-CBC,AES-XTS,AES-GCM,AES-ICM


  • LAYER 8

    uhm i have 24 static lease on my 2.4.5 and i don't have this problem, what if you remove tha last entry that lead to the problem?
    do you see the column with 13 address ?



  • Yes, when I removed the 12th entry, the Actions buttons were restored.
    Is there a limit to the number of static addresses that can be held in the DHCP table?

    12 addresses seem a little limited.

    Regards.


  • LAYER 8 Global Moderator

    Your talking about these right... I have 37 static / reservations setup

    action.jpg

    Can you post a picture of what happens.



  • Yes, exactly.
    After I added a 13th entry the Actions column disappeared. When I removed the DHCP static entries that occurred prior to this, the column re-appeared.

    It appears that the device that I added appeared to fight the DORA DHCP assignment process and wanted to hang on to its prior address. Who knows, that might have contributed to the issue.

    I added the defect report because clearly the Actions column should not have dropped out for any reason, but in my case did.


  • LAYER 8 Global Moderator

    Is like a really long host name or something? Can you post picture showing this.

    What exactly are you putting in this entry - will duplicate it here.



  • I am new to this forum so I am hoping this image attaches properly. This is what I saw: However the hostname was rather trivial: "GS108Michael" I was adding an 8 port Netgear managed switch. It does not show up in the image following. It was at the bottom of the list, scrolled off the page. This image is to illustrate what I saw.

    pfsense_nosense.PNG

    I believe the issue was that the switch wanted to hang on to it's IP address and I had to fight to get it to accept the DORA assignment. (I am still fighting it right now as I write this)
    Using the Netgear app "Smart Control Center", I have to wrangle it off of a static and onto a DHCP. Most of the time even after a reset it wants to hold on to the previous IP.
    I am guessing I need to clear the ARP table here?


  • LAYER 8

    Description is too long,
    anyway you should have a scroll bar at the end of the list, your screenshot is truncated

    Immagine.jpg



  • Thank you for your reply.
    Yes, I was hoping to find a scrollbar at the bottom, That was the major issue. There was no way to scroll to the right, nor was there any indicators that you COULD scroll to the right.

    When you mentioned that the hostname was too long, I saw that the description for my desktop "Michael Kammer Desktop I9" wrapped properly,
    The item that caused the problem: GS108TMichael, used the same hostname / Description AND client ID

    Note: I had a SECOND Netgear GS108T switch (all three elements were "GS108TTheatre", previously configured in the list and the Actions column still remained. The problem occurred when I added another identical Router with a sequential IP.
    Note: the MACS were not even close to each other, so that could not be the issue.

    so it could not have been the problem as every element in all three fields was 14 characters or less.

    In any case, when I remove the last item, everything started working normally


Log in to reply