Why is pfsense taking over port 80



  • So I am a pfsense noob obviously, and I have a question why is pfsense running port 80 over the web, I want my web server running on that port. Also I port forwarded other ports and they don't work, like they respond but they arn't doing their functions like SSH, RDP, VNC. I am totally lost.
    Also openDNS doesn't seem to be working, it's set under the DNS, but it's not working… I am starting to dislike pfsense.



  • You'd have to post your NAT and Rules configuration for us to make sense of your problem.

    As for OpenDNS, it works perfectly for me in over a dozen installations.

    Again, perhaps you can post your config and I've mislaid my crystal ball.



  • pfSense is running on port 80 unless you change it at:  System | General Setup
    Use another port or even HTTPS…



  • Specifically, he means that the webGUI interface for pfSense runs by default on TCP 80.  Change it to a port that doesn't conflict with your intended port forwards.



  • @jigglywiggly:

    So I am a pfsense noob obviously, and I have a question why is pfsense running port 80 over the web, I want my web server running on that port. Also I port forwarded other ports and they don't work, like they respond but they arn't doing their functions like SSH, RDP, VNC. I am totally lost.
    Also openDNS doesn't seem to be working, it's set under the DNS, but it's not working… I am starting to dislike pfsense.

    The most obvious choice of port for something to be reached by a web browser is port 80, the default port for http. Otherwise you'd have to append port number to the URL when browsing, so that's the most natural way to start with for a default installation. Otherwise other people would ask the opposite question instead..

    Should you want to use another port for various reasons just change it. And you probably want https anyway.

    Port forwarding is quite straight forward in pfSense I think. First go to "NAT" tab and enter the data and make sure it auto-adds a FW rule. Apply changes. Done. (Can't help thinking of Gordon Ramsey's way of saying it, writing that "recipe" LOL).
    Maybe also reset states to be sure.

    If you can't get that to work you may have chosen incorrect protocol or something, double check it.

    I'm also running OpenDNS and it's working perfectly.
    You should not be using "Allow DNS server list to be overridden by DHCP/PPP on WAN" obviously.

    You probably want to stick to it and learn how to get it to work, pfSense is probably one of the most advanced open source firewall packages in existence. When a product is so flexible and has so many options and features there's always some risk of doing things incorrectly in the beginning.

    Cheers,



  • @0tt0:

    @jigglywiggly:

    So I am a pfsense noob obviously, and I have a question why is pfsense running port 80 over the web, I want my web server running on that port. Also I port forwarded other ports and they don't work, like they respond but they arn't doing their functions like SSH, RDP, VNC. I am totally lost.
    Also openDNS doesn't seem to be working, it's set under the DNS, but it's not working… I am starting to dislike pfsense.

    The most obvious choice of port for something to be reached by a web browser is port 80, the default port for http. Otherwise you'd have to append port number to the URL when browsing, so that's the most natural way to start with for a default installation. Otherwise other people would ask the opposite question instead..

    Should you want to use another port for various reasons just change it. And you probably want https anyway.

    Port forwarding is quite straight forward in pfSense I think. First go to "NAT" tab and enter the data and make sure it auto-adds a FW rule. Apply changes. Done. (Can't help thinking of Gordon Ramsey's way of saying it, writing that "recipe" LOL).
    Maybe also reset states to be sure.

    If you can't get that to work you may have chosen incorrect protocol or something, double check it.

    I'm also running OpenDNS and it's working perfectly.
    You should not be using "Allow DNS server list to be overridden by DHCP/PPP on WAN" obviously.

    You probably want to stick to it and learn how to get it to work, pfSense is probably one of the most advanced open source firewall packages in existence. When a product is so flexible and has so many options and features there's always some risk of doing things incorrectly in the beginning.

    Cheers,

    Thanks for the advice, specifically about getting OpenDNS to work. I had the check box checked that said "Allow DNS server list to be overridden by DHCP/PPP on WAN" removing it worked nicely. Danke.


Locked