haproxy not starting



  • Hi,

    I have just downgraded my SG-3100 from 2.4.5 to 2.4.4-p3 (due to the blocking cpu causing a bit lag.) I made a backup and then I restored after flashing the 2.4.4-p3 firmware.

    Everything works except haproxy that doesnt start with this error

    # haproxy -vv
    Lua init: table index is nil.
    

    My configuration does not contain any lua script. The version I was using and the installed match: 0.60_4

    I have tried to reinstall the lua53 and haproxy packages but no luck.

    I also reflashed the device and got the same problem.
    Any clue how to solve this?

    Thanks



  • An update that is actually not an update.

    I have tried to factory settings and reflashed the firmware but same result.
    I have searched the internet an only found an old post on this same forum but the solution for them was reinstall the package (thing that did not work for me).

    I have tried to wipe the package configuration removing the folders /var/etc/haproxy but configuration is still there so I have no clue how to reset the package... Any clues here?

    In the end I have finished installing haproxy on a VM on my hypervisor. I lost the convenience of having a GUI and the auto renew of the certificates.. but I guess I'll have to live without that.


Log in to reply