Intel gigabit ct Desktop not detected



  • Hi

    I recently bought a Intel gigabit ct Desktop netcard (82574L) for my new pfsense build. It should be supported by the em4 driver.

    The onboard pro/1000 is instantly detected but the ct netcard is not.

    In pfsense em0 is showing: ahci enclosure management bridge

    I installed Windows and tested the netcard. It works fine on windows.

    The lights on the ct card turns on when i plug in the netcable.
    I tried another pci-e port.

    What am i doing wrong?



  • If i run the pciconf -lv command it shows:

    em1@pci0:0:31:6: class=0x020000 card=0x310617aa chip=0x15b78086 rev=0x00 hdr=0x00 vendor = 'Intel Corporation' device = 'Ethernet Connection (2) I219-LM' class = network subclass = ethernet

    em0@pci0:4:0:0: class=0x020000 card=0xa01f8086 chip=0x10d38086 rev=0x00 hdr=0x00 vendor = 'Intel Corporation' device = '82574L Gigabit Network Connection' class = network subclass = ethernet [2.4.5-RELEASE]

    But under assign interfaces:
    em0 (down) AHCI enclosure management bridge
    em1 (up) Intel(R) PRO/1000 Network Connection 7.6.1-k



  • @WAR10CK said in Intel gigabit ct Desktop not detected:

    AHCI enclosure management bridge

    OK, pfsense recognizes the netcard, but why is it saying : AHCI enclosure management bridge under interface em0.
    There is no link when I plugin the cable to em0.

    The cable works fine in em1.