Using a 4G Router (Huawei B535) As My WAN Access



  • Help please folks!

    As the title suggests, I'm trying to use the above 4G router for my internet access.

    It is a direct replacement for my previous cable router from my old ISP. That router allowed me to enable "modem" mode, plug it into my WAN port and allowed pfsense to handle DHCP and wifi via another AP.

    The Huawei doesn't seem to have that facility but does allow you to switch off it's own DHCP server. I thought that simply switching off the DHCP, give it a static address and plugging it in to my WAN port would do it..... Apparently not!

    I've tried all combinations of static addresses.... default settings etc but can't get pfsense to see the outside world through this router.

    Any suggestions for this, or any similar setups gratefully received.

    Paul



  • http://screenshots.portforward.com/routers/Huawei/B525s-23a/Bridge_Mode.htm

    Don't suppose you have this option.. Other posts Im seeing seem to say bridge mode is not available on it.

    You cannot have the same subnet on both LAN and WAN.. Maybe that is your issue??



  • My bad on the research front.... I just assumed that all modern routers come with a bridge/modem mode... Doh..

    Yes, I got very confused when I tried to put the router onto my LAN.... pfsense got similarly confused!

    More research is telling me that I'll never see a public IP address with a 4G service either? That suggests no dynamic DNS/open VPN abilities either?



  • No.. carriers are generally Carrier Grade NAT. Though I have seen government agencies use cameras on Verizon service that could be accessed via public IP. I need to do more research.

    My Cradlepoint is in bridge mode on my test router right now. My test router has an address of 100.103.169.98

    I see nothing today in my firewall logs today. Yesterday after I set it up in bridge mode I saw constant pings and udp traffic from other public IP's. So seems like somwhere a firewall got switched on.. I need to check the Cradlepoint closer..

    VPN. Yes you can use OpenVPN as a client behind CGN to a box running as OpenVPN server. Some MIFI's will block VPN traffic by default and have to have it switched on in the device GUI. Im not sure about your modem.


Log in to reply