Freeradius doesn't start after the upgrade to 2.4.5 base build



  • Hello all,

    I recently upgrade the pfsense to the latest build 2.4.5. After the upgrade the radiusd service doesn't start

    d933eed1-13d6-44ea-ace6-5b2d5ee16ee5-image.png

    I ran radiusd -X, I found the following suspicious error message

    Unable to check file "/usr/local/etc/raddb/certs/server_key.pem": No such file o r directory
    /usr/local/etc/raddb/mods-enabled/eap[26]: Failed parsing configuration item "pr ivate_key_file"
    rlm_eap_tls: Failed initializing SSL context
    rlm_eap (EAP): Failed to initialise rlm_eap_tls
    /usr/local/etc/raddb/mods-enabled/eap[2]: Instantiation failed for module "eap"

    Complete output: https://pastebin.com/iJH79ghm

    I tried starting service manually service radiusd onestart

    [2.4.5-RELEASE][admin@pfSense.localdomain]/root: service radiusd onestart
    Starting radiusd.

    Tried nohup radiusd &, that didn't help either

    [2.4.5-RELEASE][admin@pfSense.localdomain]/root: nohup radiusd &
    [1] 12670.

    Reinstalled the freeradius packages , uninstalled and installed it back again , none of that helped. How do I resolve this ?


Log in to reply