IPv6 connectivity from LAN is lost after PPPoE reconnect



  • Hi,

    I have a working (!) DualStack configuration working for years now with Deutsche Telekom. Configuration see below.

    What I see is that every now and then while my LAN networks still get IPv6 addresses, outbound IPv6 communication is not working. After watching this for a while it seems to be connected to PPPoE reconnects. Once the PPPoE is reconnected IPv4 works like a charm but IPv6 does not.

    What does work is that when I go to the LAN interface configuration and change the track-IP from e.g. 0 to 5, the IPv6 on the pfsense LAN interface disappears and after a while comes back (but still the same IP to the best of my knowledge so the prefix-id remains 0 and does not change to 5). BUT suddenly IPv6 from the clients behind the LAN works again.

    Is there any idea you guys can have? At first I thought that the prefix delegation (done via DHCPv6 on the WAN interface) is screwed up or the new prefixes are not attached to the LAN interface. But since the above workaround works without having me to dis-/reconnect the PPPoE it looks as if the prefixes are reaching the WAN interface just fine.

    I am at a complete loss here. Not sure if this started with 2.4.5 but that is an update I recently made and I can "reproduce" this since then. Might have been there before. By reproduce I mean that this only seems to happen if the PPPoE reconnect is triggered due to a real loss of connectivity or from the carrier. If I hit disconnect/reconnect it does not happen. Maybe something with the monitor scripts?

    What "troubles" me is that the LAN Ipv6 on the pfsense interfaces (I have three LAN interfaces with different VLANs) do not change. It appears as if everything is working but something in the routing engine or pf is messed up.

    General setup information:

    Two WAN connections.

    • One Dualstack IPv6&IPv6 Deutsche Telekom with dynamic IP
    • One IPv4 with static IPv4

    Logfile showing tonights PPPoE link loss. Maybe you can see something in it that I failed to recognize:
    log.txt

    Configuration for the main WAN and the LAN interfaces:

    1807b3b2-4d99-4b93-b3d0-9e357055e712-image.png

    1bfd9152-1826-4db0-9700-f29952459921-image.png

    9b3b2220-b138-44f0-8d8b-a72753976c27-image.png

    a24f0900-1c11-4cd7-8a75-c2d63c2ca6f6-image.png

    Would be very grateful for any hint on how to debug this.

    Regards,
    JP


Log in to reply