[Somewhat solved] SIS Card Issues? ("sisX: Applying short cable fix (reg=XX)")



  • I'm curious about this… is there some issue with Netgear FA311 (SIS) cards and FreeBSD?  I noticed this issue with pfSense and m0n0wall back before my router computer fried a while back, and since the cards still work, I'm using them again.  They seem to work fine, but occasionally all traffic halts for ~1 second, and I look at the router's monitor and I see 'short cable fix' messages.

    Here is the stuff from the system log:
    kernel: sis0: <natsemi 10="" dp8381[56]="" 100basetx="">port 0x6800-0x68ff mem 0xef003000-0xef003fff irq 9 at device 10.0 on pci0
    kernel: sis1: <natsemi 10="" dp8381[56]="" 100basetx="">port 0x6c00-0x6cff mem 0xef001000-0xef001fff irq 5 at device 11.0 on pci0
    kernel: dc0: <82c169 PNIC 10/100BaseTX> port 0x7000-0x70ff mem 0xef000000-0xef0000ff irq 11 at device 12.0 on pci0
    kernel: rl0: <realtek 10="" 8139="" 100basetx="">port 0x7400-0x74ff mem 0xef002000-0xef0020ff irq 10 at device 13.0 on pci0

    I keep seeing messages like this one:

    May 19 10:43:52 kernel: sis1: Applying short cable fix (reg=f4)
    May 19 10:43:52 kernel: sis1: link state changed to UP
    May 19 10:43:52 kernel: sis1: Applying short cable fix (reg=f4)
    May 19 10:43:52 kernel: sis1: Applying short cable fix (reg=f4)
    May 19 10:43:55 kernel: sis0: Applying short cable fix (reg=f9)
    May 19 10:43:55 kernel: sis0: link state changed to UP
    May 19 10:43:55 kernel: sis0: Applying short cable fix (reg=f8)
    May 19 10:43:56 kernel: sis0: Applying short cable fix (reg=f8)

    Now… 'short cable fix' to me says 'my cable is too short'.  So I tried all new shielded cables.  Same error pops up.  Tried un-shielded, ditto.  Tried 100' shielded and un-shielded... same problem.

    Through testing, common-sense translation of 'short cable fix' does not seem to apply here.  Perhaps there is something wrong with the SIS chips on the FA311's?  I had a ton of them and have never really had any problems with them on Windows* or any of the Linux distros I've tried out.

    [Update]    [Update]    [Update]    [Update]    [Update]    [Update]    [Update]

    Doing a google search did show this though:

    Excerpt from /usr/src/sys/pci/if_sis.c:
    /*

    • Some DP83815s experience problems when used with short
    • (< 30m/100ft) Ethernet cables in 100BaseTX mode. This
    • sequence adjusts the DSP's signal attenuation to fix the
    • problem.
      */

    So, since the Netgear FA311 cards I'm using run the sis driver, I'm guessing that BSD has issues with the cards?  Is there any way to fix the 'signal attenuation' manually?  Or perhaps have the driver store the working attenuation between boots so it isn't constantly having to re-figure the correct value?  I'd hate to have to go out and get all new cards (though Intel's from what I've seen almost never have issues).

    I'm thinking of swapping sis1 (LAN) if to the RealTek card.  Anyone had any issues with RealTek chips?</realtek></natsemi></natsemi>



  • Just another update here… it seems that whatever the problem was with the cards has mysteriously ceased.

    I started 20 torrents with the biggest dvd iso's of linux I could find and whatever else that was big enough to kill my connection for the night, reboot pfSense, and went to bed.  10 on the LAN subnet (sis1) and 10 on the OPT1 subnet (sis0).  Also had music streaming from opt1 to LAN, and wrote a simple batch file to constantly send an iso 'the ultimate boot cd' back and forth across the connections.

    So far, it doesn't seem like the error has cropped up anymore.  I'm guessing once the 'short cable fix' is set, it works from then on, even across reboots?  I don't see any more of that message other than the ones right after the cards are initialized.

    Odd thing is that before re-formatting and installing pfSense 1.2.3RC1 from the ISO instead of 1.01>updated to 1.2.3RC1, I saw this message at least 5 times an hour.  Clean install FTW?
    confused.


Locked