Freeswitch: internal calls>straight to vm when registered on lan profile



  • My Linksys PAP2T is set to register both lines to my dynamic dns address. Normally then they register to the internal profile.

    Then I created an entry in pfsense's dns forwarder directing queries for my dynamic dns domain to 192.168.3.1, the address of the pfsense interface that the PAP2T sits on. As expected, these 2 lines register to the lan profile. Outgoing calls work fine, however internal calls (Line1<>Line2) go straight to voicemail.

    Here's some output for the smarter-than-I developers:

    
    2009-05-19 00:19:57 [DEBUG] mod_dptools.c:748 set_function() sofia/lan/1001@burgess.myphotos.cc SET [called_party_callgroup]=[UNDEF]
    EXECUTE sofia/lan/1001@burgess.myphotos.cc db(insert/burgess.myphotos.cc-last_dial//71b6e312-3d44-de11-b4ee-000024cbeb68)
    EXECUTE sofia/lan/1001@burgess.myphotos.cc bridge(user/1002@burgess.myphotos.cc)
    2009-05-19 00:19:57 [DEBUG] switch_ivr_originate.c:1082 switch_ivr_originate() variable string 0 = [presence_id=1002@burgess.myphotos.cc]
    2009-05-19 00:19:57 [ERR] switch_ivr_originate.c:1495 switch_ivr_originate() Cannot create outgoing channel of type [error] cause: [USER_NOT_REGISTERED]
    2009-05-19 00:19:57 [DEBUG] switch_ivr_originate.c:2094 switch_ivr_originate() Originate Resulted in Error Cause: 606 [USER_NOT_REGISTERED]
    2009-05-19 00:19:57 [ERR] switch_ivr_originate.c:1495 switch_ivr_originate() Cannot create outgoing channel of type [user] cause: [USER_NOT_REGISTERED]
    2009-05-19 00:19:57 [DEBUG] switch_ivr_originate.c:2094 switch_ivr_originate() Originate Resulted in Error Cause: 606 [USER_NOT_REGISTERED]
    2009-05-19 00:19:57 [INFO] mod_dptools.c:2074 audio_bridge_function() Originate Failed.  Cause: USER_NOT_REGISTERED
    2009-05-19 00:19:57 [DEBUG] mod_dptools.c:2101 audio_bridge_function() Continue on fail [true]:  Cause: USER_NOT_REGISTERED
    EXECUTE sofia/lan/1001@burgess.myphotos.cc answer()
    2009-05-19 00:19:57 [DEBUG] mod_dptools.c:649 answer_function() sofia/lan/1001@burgess.myphotos.cc receive message [ANSWER]
    2009-05-19 00:19:57 [DEBUG] sofia_glue.c:2146 sofia_glue_activate_rtp() AUDIO RTP [sofia/lan/1001@burgess.myphotos.cc] 192.168.3.1 port 26534 -> 192.168.3.2 port 16434 codec: 0 ms: 20
    2009-05-19 00:19:57 [DEBUG] switch_rtp.c:906 switch_rtp_create() Starting timer [soft] 160 bytes per 20ms
    2009-05-19 00:19:57 [DEBUG] mod_sofia.c:534 sofia_answer_channel() Local SDP sofia/lan/1001@burgess.myphotos.cc:
    v=0
    
    

    Let me know what I did wrong, or what I can do to help you find out what you did wrong.

    db


Locked