• Hello,

    i have a Fatal trap 12 error evrytime when my pfsense is on. pfsense is installed in a qotom pc with intel core I5, 8G of Ram, 64g M2 ssd and 6 intel nics

    i have :

    • change RAM with an other pfsense machine that does not have the problem -> i have the same error
    • change the HDD and reinstall -> i have the same error
    • change the power supply -> i have the same error
    • minimize infrastructure to have : box -> pfsense -> switch -> PC ->i have the same error
    • execute a CPU stress test and memtest -> no errors
    • i have try with the 2.4.4 version and with 2.5 vesrion -> i have the same error

    I join you after the crash repport.

    report Fatal trap 12.txt

    have you any ideas of the origin?

    sorry for my poor English.

    thank you verry much for your help.

  • Netgate Administrator

    The important part of this is this:

    db:0:kdb.enter.default>  show pcpu
    cpuid        = 2
    dynamic pcpu = 0xfffffe02a54cc400
    curthread    = 0xfffff801c7da7000: pid 48915 "sh"
    curpcb       = 0xfffffe0232708a80
    fpcurthread  = none
    idlethread   = 0xfffff80006218000: tid 100005 "idle: cpu2"
    curpmap      = 0xfffff801c7dd2138
    tssp         = 0xffffffff82cadf60
    commontssp   = 0xffffffff82cadf60
    rsp0         = 0xfffffe0232708a80
    gs32p        = 0xffffffff82cb47b8
    ldt          = 0xffffffff82cb47f8
    tss          = 0xffffffff82cb47e8
    tlb gen      = 56962
    db:0:kdb.enter.default>  bt
    Tracing pid 48915 tid 100247 td 0xfffff801c7da7000
    kdb_enter() at kdb_enter+0x3b/frame 0xfffffe0232708320
    vpanic() at vpanic+0x19b/frame 0xfffffe0232708380
    panic() at panic+0x43/frame 0xfffffe02327083e0
    trap_pfault() at trap_pfault/frame 0xfffffe0232708430
    trap_pfault() at trap_pfault+0x49/frame 0xfffffe0232708490
    trap() at trap+0x29d/frame 0xfffffe02327085a0
    calltrap() at calltrap+0x8/frame 0xfffffe02327085a0
    --- trap 0xc, rip = 0xffffffff810b9a03, rsp = 0xfffffe0232708670, rbp = 0xfffffe02327086d0 ---
    vm_fault_prefault() at vm_fault_prefault+0x213/frame 0xfffffe02327086d0
    vm_fault_hold() at vm_fault_hold+0x1f11/frame 0xfffffe0232708800
    vm_fault() at vm_fault+0x75/frame 0xfffffe0232708840
    trap_pfault() at trap_pfault+0x165/frame 0xfffffe02327088a0
    trap() at trap+0x431/frame 0xfffffe02327089b0
    calltrap() at calltrap+0x8/frame 0xfffffe02327089b0
    --- trap 0xc, rip = 0x40fd99, rsp = 0x7fffffffe570, rbp = 0x7fffffffe5a0 ---
    db:0:kdb.enter.default>  ps

    But the console log also shows:

    MCA: Bank 0, Status 0x9000004000010005
    MCA: Global Cap 0x0000000000000c08, Status 0x0000000000000000
    MCA: Vendor "GenuineIntel", ID 0x806e9, APIC ID 3
    MCA: CPU 3 COR (1) internal parity error

    That is almost certainly a hardware fault.


  • thanks for your answer

    i am sorry for the repport where the MCA error in, it appearsed when i validated the hypertrheading desactivating
    following an information found on free bsd forum it's the only time where i have had this error.

    to ensure myself i have again checked with cpu stess test and it's ok

    i have continued my test and in the 10 other repports this error does not appaer

    i join you in the code parts the important part and in a file the full error log of the last crash

    db:0:kdb.enter.default>  show pcpu
    cpuid        = 2
    dynamic pcpu = 0xfffffe02a54cb400
    curthread    = 0xfffff8022146c000: pid 81043 "egrep"
    curpcb       = 0xfffffe0232622a80
    fpcurthread  = 0xfffff8022146c000: pid 81043 "egrep"
    idlethread   = 0xfffff80006218000: tid 100005 "idle: cpu2"
    curpmap      = 0xffffffff82c7cd78
    tssp         = 0xffffffff82cadf60
    commontssp   = 0xffffffff82cadf60
    rsp0         = 0xfffffe0232622a80
    gs32p        = 0xffffffff82cb47b8
    ldt          = 0xffffffff82cb47f8
    tss          = 0xffffffff82cb47e8
    tlb gen      = 2534
    db:0:kdb.enter.default>  bt
    Tracing pid 81043 tid 100199 td 0xfffff8022146c000
    kdb_enter() at kdb_enter+0x3b/frame 0xfffffe02326223e0
    vpanic() at vpanic+0x19b/frame 0xfffffe0232622440
    panic() at panic+0x43/frame 0xfffffe02326224a0
    trap_pfault() at trap_pfault/frame 0xfffffe02326224f0
    trap_pfault() at trap_pfault+0x49/frame 0xfffffe0232622550
    trap() at trap+0x29d/frame 0xfffffe0232622660
    calltrap() at calltrap+0x8/frame 0xfffffe0232622660
    --- trap 0xc, rip = 0xffffffff810c73c0, rsp = 0xfffffe0232622730, rbp = 0xfffffe0232622780 ---
    vm_object_deallocate() at vm_object_deallocate+0x60/frame 0xfffffe0232622780
    _vm_map_unlock() at _vm_map_unlock+0xd9/frame 0xfffffe02326227a0
    vm_map_remove() at vm_map_remove+0xaa/frame 0xfffffe02326227d0
    vmspace_exit() at vmspace_exit+0xc9/frame 0xfffffe0232622810
    exit1() at exit1+0x5e9/frame 0xfffffe0232622870
    sys_sys_exit() at sys_sys_exit+0xd/frame 0xfffffe0232622880
    amd64_syscall() at amd64_syscall+0xa86/frame 0xfffffe02326229b0
    fast_syscall_common() at fast_syscall_common+0x101/frame 0xfffffe02326229b0
    --- syscall (1, FreeBSD ELF64, sys_sys_exit), rip = 0x800f5acaa, rsp = 0x7fffffffeb68, rbp = 0x7fffffffeb80 ---
    db:0:kdb.enter.default>  ps


    if you know how to make an another test to the CPU please let me know

    Thanks for your help

  • Netgate Administrator

    Hmm, well both are in virtual memory operations but nothing concrete shown there.

    Nothing jumped out in the console log but do you have anything unusual running there? Any odd hardware?


  • Many thanks Steve for your help

    no i have reinstall pfsense specifically for test with no other package and just the origin firewall rules. I have reduce the network a the minimal install operator box -> pfsense -> pc, i have only modify in the miscellaneous to AES-NI and BSD Crypto Device (aesni, cryptodev) for the Cryptographic Hardware because before i have a fatal trap 14 . if you want i can send the conf file or other file which would be usefull, just tell me how i can do that because i don't have a great experience with pfsense.

    thanks you very much

  • Netgate Administrator

    Hmm, well if it's a minimal config like that on a clean install there is not much to go wrong.

    How long does it take to panic?


  • between 1 and 36 hours



  • Netgate Administrator

    It seems like almost certainly a hardware problem unfortunately.

  • Tanks for your help.

    i have seen with an other pc and only the other pc on the network, that there is no problem for 56 hours and when i reconnect my first pc the error appears in 3 hours.
    i checked this idea and if it doesn't solve the problem i will see to RMA with the retailler of the pc where pfsense is installed.
    i will post the solutions of this test.

    many thanks for your help

    have nice day


  • Hi,

    i have resend the the pc to the retailler who sent me back a new motherboard with cpu and nic integrated. It's now ok

    many thanks for your help