NAT with Virtual IP (OWA)



  • Hello All!

    Newbie to pfSense (2.4.5-RELEASE) here, please be patient! 😖

    I am moving over from a ZyXel USG 60 and having difficulty with my OWA Server.

    I have a /29 subnet from my ISP and my gateway is in bridge mode, so my pfSense is getting my WAN IP's.

    Previously, I had my OWA Server using one of my virtual IP's (x.x.58.8), not the primary IP (x.x.58.5). So when accessing the internet on that machine it would show the virtual IP. I only allowed https in on that machine.

    I want to replicate that on my pfSense FW. I am going to investigate Squid in the future, but I NEED to get my OWA server accessible as no one can access email on their phones remotely.

    I have searched and watched videos, but have been unsuccessful so far.

    I believe I need a 1:1 NAT, and a rule allowing 443. Is that all?

    Thanks in advance!

    Kyle



  • You have to add all your public IPs as IP alias (Firewall > Virtual IPs).

    Then go to Firewall > NAT > Port Forward and add a rule to forward port 443 to your OWA server. The destination is your virtual public IP.
    In the rule settings you can select that pfSense adds an assigned firewall rule automatically.

    With 1:1 NAT pfSense uses the entered public IP also for outbound connections from the stated internal device and the 1:1 conjunction is applied to any ports. This may be not necessary in this case, but is possible as well. However, using 1:1 NAT you must add firewall rules manually.


Log in to reply