NRPE v2 Package



  • Thank you for implementing NRPE v2 into Pfsense,
    but there is a bug in the check_procs …

    when i execute /usr/local/libexec/nagios/check_procs -w 5 -c 10 -s Z
    i get :

    /libexec/ld-elf.so.1: /lib/libc.so.7: version FBSD_1.1 required by /usr/local/libexec/nagios/check_procs not found

    and another suggestion to the web interface :

    is it posible to add a free field for implenting custom checks ?
    we a using additional shell scripts executed by nrpe to do more than the nrpe default checks .

    Thanks for your good work

    Regards,
    Wolfgang



  • same problem here

    ./check_ping
    /libexec/ld-elf.so.1: Shared object "libintl.so.8" not found, required by "check_ping"



  • when i use the version from ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-7.1-release/net-mgmt/  nagios-plugins-1.4.12_1,1.tbz it works .

    Is it save to use this version ?



  • @mikesamo:

    same problem here

    ./check_ping
    /libexec/ld-elf.so.1: Shared object "libintl.so.8" not found, required by "check_ping"

    I also have this problem, running the check_tcp plugin, same error message. I tried replacing them with the versions from the above link but it didn't work.

    Then I went nuts and tried installing all sorts of packages until I got to a point where things really started to get fucked up, and I ended up reinstalling from scratch and restoring my config. At least I learned a lot in the process.

    So here is some other info:

    
    # ldd /usr/local/libexec/nagios/check_tcp
    /usr/local/libexec/nagios/check_tcp:
            libssl.so.5 => /usr/lib/libssl.so.5 (0x28082000)
            libcrypto.so.5 => /lib/libcrypto.so.5 (0x280c3000)
            libintl.so.8 => not found (0x0)
            libiconv.so.3 => not found (0x0)
            libc.so.7 => /lib/libc.so.7 (0x2821d000)
    
    

    It seems to be missing those two libraries. From what I gathered previously, they seem to have something to do with gettext/texinfo/libiconv(maybe) packages. I think previously I was able to successfully install the last one with
    pkg_add -r libiconv

    but trying to install the others gave errors related to not being able to find "install-info" which I verified doesn't exist anywhere on a system with a fresh 1.2.3-RC1 install. Interestingly enough, it does exist on a system I upgraded from 1.2.2 to 1.2.3-RC1. I tried to scp it but it didn't work (something about a newline).

    As I'm sure is obvious from my post, I have very little experience with FreeBSD, so please bear with me. If someone could help me out, I'd really appreciate it.

    Edit:

    **** SOLVED ****

    I don't know what happened this time exactly. On a whim, I followed the list of packages here (excluding the openvpn specific one), and after installing gcc and gmake the libraries are there. This has been some night..


Log in to reply