Solution for HomeKit in Different L2 Network Than Hue Bridge?

  • Hi,

    I have all my items and stuff in a separated L2 network. So there I have my Hue Bridge and it is running fine with the Hue app and the attached light bulbs. Seems to be perfect.

    My iPhones are connected to a different network (different interface on pfSense). HomeKit tells me: Bulbs not connected.

    When I connect my iPhone to the same L2 network all is fine and runs perfectly.

    Now I read a lot of threads of adding the avahi daemon to pfSense which I did. But still no luck.

    I have configured current version of avahi package (v2.1.1) to be enabled and allow both affected interfaces.
    IPv4 is allowed and all filter rules allow traffic (for testing purposes) from both directions to the other network. Avahi daemon is configured to "repeat mDNS packages to other subnets".

    Still no luck. As soon as I connect my iPhone to the same L2 network it is rnning fine.

    Anyone having a solution for this issue?

    Thanks a lot!


  • [Update]

    Well, looks like I have not been patient enough.

    After a couple of minutes it worked flawlessly.
    For any other guys having the same issue here are my settings (all others are disabled):



  • Add your domain name to Avahi>Advanced Settings>Override Domain to reduce the wait time. The default Override domain name used for publishing mdns records is "local", which is most likely not the domain name in use.

Log in to reply