Upgrade in place to 2.4.5 failed; reinstalled from scratch



  • I have a Netgate APU that had been running pfSense for more than a year. I believe I was running 2.4.4-p1 but I'm not certain. I noticed yesterday that an update was available so I backed up my config and told pfSense to upgrade. I watched on the Web GUI as it downloaded and updated/installed 118 packages and then rebooted. The Netgate made the "I'm booting" noise, but the pfSense GUI never came up.

    I connected to the serial console and found that I reached the pfSense menu, but no menu items would work. I'm cutting and pasting from another poster because I did not capture my serial output, but I saw something akin to this:
    563cfa81-1079-46ce-97e8-d51042f23b53-image.png
    I could select any menu option, but none of them would do anything -- I'd simply get PHP Startup messages and segmentation faults.

    I ended up reinstalling from scratch using a USB memory stick and the pfSense-CE-memstic-serial-2.4.5-RELEASE-p1-amd64.img image. It's up and working again, but it's frustrating that the upgrade-in-place process resulted in a non-working configuration.


  • Rebel Alliance Developer Netgate

    There isn't enough information there to tell us why it might have failed, unfortunately. We can't test every possible combination of old version upgrades, we usually test a couple versions back (like 2.4.5->2.4.5-p1, and 2.4.4-p3->2.4.5-p1) but I don't know that anyone tried 2.4.4-p1 specifically since it's rather old/out of date.



  • Same problem with me, first client update 245 to 245-p1 core dumped - crash


  • Rebel Alliance Developer Netgate

    @Ivart said in Upgrade in place to 2.4.5 failed; reinstalled from scratch:

    Same problem with me, first client update 245 to 245-p1 core dumped - crash

    Do you have any logs/details about the crash that might help us identify what happened? If so, start a new thread and include them there since it's unlikely to be anything related to this thread.



  • Last night I did update remotely from 2.4.5 to 2.4.5 p1 on my first client, after few minutes can´t connect through VPN Server, today I download 2.4.5 p1 image and write on a pen drive, now I´m on client site, tried reinstall but found same problems, a lot of libraries not found e core dump, to resolve this problem I´ve get back 2.4.5 and restored a backup, I wil try this img on VM when back to office.


  • Rebel Alliance Developer Netgate

    If you had problems after a reinstall, it's probably hardware and or the process you tried, and not a problem in pfSense. It could be a disk issue, when some SSDs wear out they may act like they are taking writes but are not actually writing. Either way it's not the same issue as OP so it belongs in its own thread.



  • @jimp - thanks for the note. It sounds like the safe approach for me to take is to apply all upgrades shortly after they become available, so that any upgrade I perform will be from a quite recent predecessor to the current release, rather than from quite-old to quite-new.

    In practice this means a change in behavior for me because I frankly don't visit the pfSense page or log in to my firewall appliance that frequently. One of the beauties of pfSense is that "it just works", so I don't usually have call to go look at it unless something is going wrong.

    In the past I've had challenges with upgrades (I've been using pfSense for more than 10 years now) and I suppose I learned implicitly that when I touch it, I tend to break it. As a result I tend to leave it alone instead of doing regular maintenance. Perhaps I need to take the other approach: tend to it more regularly and, because I'm making more frequent but incremental updates, it'll respond better than if I were to make fewer and more significant configuration changes.


  • Rebel Alliance Developer Netgate

    Given that pfSense is a security product, keeping it up-to-date is critical to ensure that known security issues are addressed regularly. You don't have to jump right on every new release the moment it's out, but you should be getting things updated regularly.

    There is more general advice in the upgrade guide to help ensure things go smoothly.


Log in to reply