Suricata não instala



  • Bom dia pessoal,

    Estou tentando instalar o pacote do Sucicata no pFsense é relatado o erro que vou postar logo abaixo.
    A versão do pFsense é:
    2.4.5-RC (amd64)
    construído em Tue Mar 17 12:05:53 EDT 2020
    FreeBSD 11.3-STABLE
    A versão do Suricata que estou tentando instalar é a:
    Suricata 4.1.7

    Falha:
    readline: 8.0.1 -> 7.0.3_1 [pfSense]
    sqlite3: 3.30.1 -> 3.28.0 [pfSense]
    strongswan: 5.8.2 -> 5.7.1 [pfSense]
    unbound: 1.9.6 -> 1.9.1 [pfSense]

    Number of packages to be removed: 15
    Number of packages to be installed: 19
    Number of packages to be downgraded: 7

    The operation will free 8 MiB.
    pkg-static: Cannot delete vital package: pfSense!
    pkg-static: If you are sure you want to remove pfSense,
    pkg-static: unset the 'vital' flag with: pkg set -v 0 pfSense
    Falhou

    Se puderem me ajudar, agradeço muito. Estou sofrendo uns ataques e gostaria de mitigar as chances de sucesso dele.



  • You may get a better response to this by posting your issue in your native language forum, but I will give it a shot based on what I can read and understand from your screenshot dump.

    It appears that you have an older version of pfSense (the early 2.4.5-RC or Release Candidate). You can't upgrade or install any packages until your pfSense version is current with what the packages repository is based upon. In your case, you should first upgrade your firewall to pfSense-2.4.5_p1. Only after that is completed should you attempt to install any new packages or update any existing ones.



  • @bmeeks said in Suricata não instala:

    You may get a better response to this by posting your issue in your native language forum, but I will give it a shot based on what I can read and understand from your screenshot dump.
    It appears that you have an older version of pfSense (the early 2.4.5-RC or Release Candidate). You can't upgrade or install any packages until your pfSense version is current with what the packages repository is based upon. In your case, you should first upgrade your firewall to pfSense-2.4.5_p1. Only after that is completed should you attempt to install any new packages or update any existing ones.

    Understand. Really, I looked better now and saw that there is a new version. Sorry for posting in the not ideal place, I'll be more careful next time. Thank you very much for your support, have a good day.



  • @joaquimnt said in Suricata não instala:

    @bmeeks said in Suricata não instala:

    You may get a better response to this by posting your issue in your native language forum, but I will give it a shot based on what I can read and understand from your screenshot dump.
    It appears that you have an older version of pfSense (the early 2.4.5-RC or Release Candidate). You can't upgrade or install any packages until your pfSense version is current with what the packages repository is based upon. In your case, you should first upgrade your firewall to pfSense-2.4.5_p1. Only after that is completed should you attempt to install any new packages or update any existing ones.

    Understand. Really, I looked better now and saw that there is a new version. Sorry for posting in the not ideal place, I'll be more careful next time. Thank you very much for your support, have a good day.

    No problem and no need for an apology. I was just suggesting that your native language forum might generate a quicker reply. I could read and understand some of the pfSense log output, but the portions of your post in your native language I could not understand as I am an English-only speaker. That's a shortcoming on my part and not yours, though.



  • Perfect, my friend. Thanks again for your helpfulness. I managed to solve the problem, it was so simple that I was ashamed now. lol
    Hug!


Log in to reply