Website fails to connect



  • Hello,

    I have been using Gandi Live DNS for months now. However, since yesterday it stopped working. I have recently updated to 2.4.5-RELEASE-p1, not sure if that is the issue.

    The problem is that the following URL required for Gandi DNS fails to connect,

    $ curl -v  https://dns.api.gandi.net/api/v5/nameservers/gandi.net
    *   Trying 213.167.231.6:443...
    * TCP_NODELAY set
    * Connected to dns.api.gandi.net (213.167.231.6) port 443 (#0)
    * ALPN, offering h2
    * ALPN, offering http/1.1
    * successfully set certificate verify locations:
    *   CAfile: /etc/ssl/certs/ca-certificates.crt
      CApath: /etc/ssl/certs
    * TLSv1.3 (OUT), TLS handshake, Client hello (1):
    * OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to dns.api.gandi.net:443 
    * Closing connection 0
    curl: (35) OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to dns.api.gandi.net:443
    

    The URL itself is fine as i have checked it with another ISP.

    My pfsense router is setup to use PPPoE and sits behinds a bridged modem. If i let the modem do the routing/pppoe, then the URL is reachable. So there is something in pfsense which is causing the said website not to respond.

    If i do a telnet to the port 443 of the website, then i do get a response

    $ telnet dns.api.gandi.net 443
    Trying 213.167.231.6...
    Connected to dns.api.gandi.net.
    Escape character is '^]'.
    

    So, the firewall is not blocking the connection. However, i dont understand why the SSL connection does not work.

    Anybody has a clue?

    Thanks



  • Solved.
    I set the MTU of the PPPoE interface to 1472 and the website connected fine. After that i removed the MTU setting and it is connecting at 1492.



  • @trumee Did you solve this problem yourself? Because just recently you asked for help)



  • @valentinius Yes, as i posted above the issue is resolved.


Log in to reply