Captive portal stopped working after adding new interfaces



  • I had pfsense rc1 running just fine on a box with 2 interfaces and captive portal worked like a champ ( no auth).  I just want the splash page to indicate an 'acceptable usage' policy.  After adding the two interfaces and configuring one of them for out-of-band management and the other will be used for carp when I have time to build a 2nd pfsense box the captive portal option no longer works.  I can get out to the web just fine when it is disabled.  clients receive  dhcp from another server.

    Thanks,

    Eric



  • Also, under status:Captive portal,  the mac addresses no longer appear.  I enabled the 4th interface even though I am not ready to connect it yet and will try a reboot as well

    That did not work.  I will go to the console and start from scratch.



  • that did not work either. I will disable the two added interfaces in bios (the orginal values) and start again from scratch.  It is a shame as I wanted to have out-of-band management & failover running.



  • @egarnel:

    Also, under status:Captive portal,  the mac addresses no longer appear.

    This sounds like a broken install to me. I suggest reinstalling the latest snapshot from scratch and setting it up again. It should work.



  • I tried to push it up via firmware upgrade to save some time, but no go.  I will wipe the box & reload. This time I will enable the other two nics in bios prior to the install


Locked