Freeradius - changes to /etc/raddb/users not working



  • Hi

    I've downloaded and installed/enabled freeradius through the web interface in pfsense. I've not made any changes to the config files of freeradius. It works as it is.
    But I've tried to add users manually to the users file of freeradius by using the webgui of pfsense.
    I go to Diagnostics->edit file and load /usr/local/etc/raddb/users
    I add some additional users and save the file.
    I restart freeradius by going to Status->services and stopping it and then starting it.
    When I go to Services->freeradius the users I just added through the users file is not in the listed table.
    I've also tried to run

    /usr/local/etc/rc.d/radiusd.sh restart
    

    as a shell command.
    The real deal is of course that I want to add a lot of users at once. I've a users file with 126 users and passwords set up like this:

    user1 User-Password == "pass1" 
    
    	Framed-IP-Address = 192.168.1.1
    user2 User-Password == "pass2" 
    
    	Framed-IP-Address = 192.168.1.2
    

    …etc.

    Is pfSense/FreeRadius using a database or another file than users for this and not the users file at all?
    When I add a single user by going to Services->freeradius the new user will appear in the users file and delete my changes to the file, so I'm guessing the users are stored somewhere else. But where and how do I get to that file or database?

    Hope someone can help :)


Locked