DNS+Dual Lan+Dual WAN



  • I currently have a setup with dual-Wan (outgoing load balanced) and dual-lan (one lan and one wireless lan).

    The problem is that the DNS forwarder doesn't seem to work properly on the wireless lan. I tried to set up static routes for the DNS servers, which I set at system->general setup but couldn't ork it out.

    A workaround for it has been to set manually the DNS ip's on the wireless clients. However, even setting manually the dns ip on the clients, the webconfigurator isn't reachable but I can surf the net. I tried typing the lan ip (15.0.0.1) and the firewall  name in the browser. I can't even reach it doing ping to 15.0.0.1.

    How do I set static routes properly for dns to work on both lan and wlan, and how can I reach the webconfigurator through the wlan?

    Thankyou.



  • Does it work if you disable loadbalancing at the opt lan (put default gateway for the pass firewallrule at opt-lan)? If that is the case add a rule on top of your balancing rule that uses the default gateway for the opt-lan subnet. I think we fixed some problems with the loadbalancer and some situations that might occur if using a balance everything rule. What version are you running?



  • I'm runing RC1a. Tried an early July Releng snapshot to test openvpn but it crashed many times and I went back to RC1a.

    Will try what you say tomorrow cause today is a bit late already.

    BTW system hang completely when trying to setup an openvpn server with pki infrastructure, webconfigurator became unaccessible  through any interface and only a reset to factory defaults from serial console could solve the problem.

    Thanks



  • Tried adding a rule (opt->any with gateway WAN1) on top of the balancing rule (opt->any through Balancer) but no go. The only thing that lets me surf the net is adding manually DNS to the wireless clients and even so, webconfigurator isn't reachable.

    It seems like the DNS forwarder doesn't work ok on the OPT interface. Could I solve it adding DNS's on the DHCP server for the OPT interface?

    THanks



  • Solved using this procedure:

    1-Leave DNS forwarder enabled.
    2-Place DNS in  Services->DHCP server for OPT1. This allows correct host name resolving
    3-NOT allow DHCP on wan to override DNS set in System General Setup.
    4-Add a rule to allow acces from OPT1 to 15.0.0.1 (OPT1 interface webconfigurator) with Gateway set to default instead of Loadbalancer.

    Thanks


Locked