Webserver - goes to the pfsense box instead



  • Hi there hoping for answer :)
    i am kinda new with this . so hope i can get answer.

    i got a webserver at my home to,
    when i type in my public ipadress/wan adress it goes to the Pfsense box and not my webserver.
    Why?



  • Set the webinterface of the pfSense to a different port than 80.



  • Go to "System- Advanced- down to Network Address Translation - Uncheck "Disable NAT Reflection".  Id reboot the box to make sure it takes but you may not need to…

    My box is still set to port 80. I see my webserver fine by looking at my domain name...



  • @chrisboy99:

    Hi there hoping for answer :)
    i am kinda new with this . so hope i can get answer.

    i got a webserver at my home to,
    when i type in my public ipadress/wan adress it goes to the Pfsense box and not my webserver.
    Why?

    You should assume that something may not work as intended when you use an IP# not existent on the network you're in (LAN), as a general reflection. You need something, routing, FW-rules etc then. NAT reflection I don't use, I enter overrides for domains instead, I think that's more straightforward and it's easily checked in the table if something isn't working (client side issues apart).

    I would guess you should be able to port forward ext 80 to your internal www-server: <any port="">even if pfSense uses the same port, but I have changed mine any way so I don't know. You can't make adminGUI exportable though with same port and IP# on the outside naturally.

    Cheers,</any>



  • to GruensFroeschli.

    • how do i do that?


  • System –> General Setup --> webGUI port



  • @chpalmer:

    Go to "System- Advanced- down to Network Address Translation - Uncheck "Disable NAT Reflection".   Id reboot the box to make sure it takes but you may not need to…

    My box is still set to port 80. I see my webserver fine by looking at my domain name...

    awesome.  just had the same problem and this fixed it immediately…and a reboot wasn't necessary.  thanks!


Log in to reply