/usr/local/bin/node: Undefined symbol "nghttp2_option_set_max_settings" error when i try to run node



  • i am using pfsense version 2.4.5-RELEASE.
    i want to use node js in it but when i try to use or try to view version . i get the error
    /usr/local/bin/node: Undefined symbol "nghttp2_option_set_max_settings"


  • Rebel Alliance Developer Netgate

    node is not a supported package on pfSense. It is not available in the package repository/server. If you installed it from an outside source, like FreeBSD, the errors are likely due to mismatches in the version and/or options of various libraries it expects.

    Most likely, whatever you are attempting to do with node doesn't belong on a secure firewall.



  • okk, but its solved now :)


Log in to reply