SG-2220 goes belly up after update



  • I just updated my SG-2220 to the suggested update using the software update tool in the web interface. It downloaded and installed the update. Then went to the normal web page showing it was waiting to reconnect after installation. It gave the standard countdown. That countdown ended and it went to the waiting 20 seconds countdown. Then it continued to reset and give me the will retry in 20 seconds. Just kept doing that. All the while, it gave me solid green lights for the WAN and LAN interfaces as well as the status light. I unplugged it from power and plugged it back in, the same lights went green almost immediately.

    I connected to the console port via Putty and had an 'OK' prompt. I could use '?' to give me a list of commands. 'ls' gives me a list of directories. I used the 'reboot' command. I have the option (F12) to select the boot device. I have tried letting it boot itself and selecting the built-in storage (option 1). Either way, I get the following:

    alt text

    I have not tried removing the optional m.2 SATA. The m.2 SATA section of the manual indicates it is the first to boot. I might try pulling it to see if it will boot up.

    Anyone else experience this?



  • I am hoping to get this back up and running. I am planning on moving up to the SG-3100 at some point. If I cannot get this up and running I would really like to get the config off it to use when I get the SG-3100

    I noticed in the manual that the m.2 SATA boots first. I have that installed and might try and pull that tomorrow to see if it boots ok without it.



  • Read some other messages in the same forum. Like https://forum.netgate.com/topic/155208/sg-2440-boot-failure

    Note that the "remove power' option should be used as a last resort. The (disk based) file system is probably not going to like it.
    Do not underestimate the benefits of an UPS.

    @Ravenslair said in SG-2220 goes belly up after update:

    I connected to the console port

    Always prefer this one.
    It permits you to reboot the system if the GUI isn't a viable.

    if needed, contact Netgate support for a new image so you can re install.



  • @Gertjan
    Is it possible to pull a config file off it from the console? I do not have a recent backup.... and broke the rule and did not backup before updating. If I get a new image I assume any confit present is gone? I would prefer not to have to redo all my subnets and rules.

    Power was only removed after the “wait 20 seconds” kept looping. Probably should have just let it loop and loop and maybe it would have recovered. Who knows at this point.



  • Yep, a config backup and an initial pre reboot before any major updates is not a luxury.

    If the partition info is gone, a new install will write new partition table info to the disk, create the the partitions, which will "take care" of all the info stored on it.
    Let's face it : if the partition was readable, it could have been repaired (see the Netgate => fsck video) and the config would have been accessible.

    Their is a third save net : if you activated the auto config backup tool that Netgate offers, and you do remember the password, and (I presume) the Netgate device ID stays the same (because your device stays the same) you would be able to restore from that source after install.

    Your next bet will be : unmount the disk physically, hook it up to another PC type device with some low level disk tools like Partition Magic or comparable. These tools can read the entire disk, and 'understand' many partitions types.



  • @Gertjan I am not sure I understand all of what you are saying.

    From what I have read, it sounds like the config is located in the /conf/ folder. I will check that. I will also see if I can get to a command prompt as noted in the fsck video. If I am able to then I will try the commands noted in the video. Right now, I want to see if I can pull the firewall config off the device. If I have to install a new image that is fine. I just want to get the config off before the reimage.



  • I pulled the optional 60GB m.2 SSD and powered it up. It went through the normal boot cycle looking for a location to boot from. Looks like a need an image to load. Will likely need a new m.2 SSD as well unless I can salvage this one. I contacted Netgate and they got back to me within a few hours with the firmware and steps needed to try to recover. Big shout out to Netgate for being supportive and responsive. Will try to recover and get back up and running. Still going to buy an SG-3100 for the additional throughput.


Log in to reply