squidGuard not upgrading



  • Just upgraded squid to 0.4.44_29, it did not confirm a successful upgrade as I am used to but after a reboot it showed the new version in the package manager.

    then I tried to upgrade squidGuard again
    pkg=pfSense-pkg-squidGuard&from=1.16.18_5&to=1.16.18_6
    with no success.

    Running on 2.4.5-RELEASE-p1 (amd64)
    HW: pcengines

    Any help would be great.



  • Try stopping any running squidGuard instance that might be running. A running process seems to cause issues with the installation by locking certain files.

    Stop squidGuard and then get to a shell prompt on the console and verify no squidGuard processes are running. If you see any, kill them. Then try installing the package again.



  • As of today, I upgraded to squid 0.4.44_30
    I stopped the services

    then I tried again to install pfSense-pkg-squidGuard 1.16.18_6
    I thought I noticed before a Success or something, in either case when going back to the Package Manager
    it does not show upgraded.

    How do you verify on prompt that no squidGuard processes are running?
    I did try: killall -9 pkg-static

    ll repositories are up to date.
    Checking integrity... done (0 conflicting)
    The following 1 package(s) will be affected (of 0 checked):

    Installed packages to be UPGRADED:
    pfSense-pkg-squidGuard: 1.16.18_5 -> 1.16.18_6 [pfSense]

    Number of packages to be upgraded: 1
    [1/1] Upgrading pfSense-pkg-squidGuard from 1.16.18_5 to 1.16.18_6...
    [1/1] Extracting pfSense-pkg-squidGuard-1.16.18_6: .......... done
    Removing squidGuard components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    Deinstall commands... done.



  • This command should show any running squid or squidGuard processes:

    ps -ax | grep squid
    

    Look at the output of that command and note the Process ID <pid> of any running squid or squidGuard processes and kill them using this command:

    kill -9 <pid>
    

    Replace <pid> in the above command with the numerical Process ID you see displayed for any running processes with the first command.



  • with ps -ax | grep squid

    28301 - S 0:00.38 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    28482 - I 0:00.14 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    28523 - I 0:00.13 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    28634 - I 0:00.13 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    45685 - Is 0:00.01 /usr/local/sbin/squid -f /usr/local/etc/squid/squid.c
    46066 - S 0:29.10 (squid-1) --kid squid-1 -f /usr/local/etc/squid/squid

    Does that look normal?
    since I am not able to upgrade squidguard I could kill the top 4 processes.

    Everytime I kill one it creates more processes, as you can see I killed the first 2

    28523 - S 0:00.13 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    28634 - I 0:00.13 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    46931 - S 0:00.12 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    47021 - S 0:00.12 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    47155 - S 0:00.12 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    47483 - S 0:00.12 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    87871 - I 0:00.13 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    88100 - I 0:00.13 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    88325 - I 0:00.13 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.
    88342 - I 0:00.13 (squidGuard) -c /usr/local/etc/squidGuard/squidGuard.

    Through the UI pfsense I stopped the following services:
    c-icap
    squid

    sometimes squid stops and sometimes it does not.
    I also tried
    killall -9 squidGuard
    kill -9 pgrep squidGuard

    no success



  • I was able to upgrade, how?
    Uninstalled squidGuard about 4 times
    reboot
    Uninstalled again
    then installed the new version
    reinstalled squid (Since it was not green the last time I installed)
    rebooted
    seems to work

    thanks for your help



  • Man, it sounds like Squid or squidGuard was some kind of unkillable zombie from the Apocalypse...😀.

    There was probably a parent process in that list, and all the rest were children of that parent. Killing a child process likely resulted in the parent immediately relaunching it.

    Glad you got it sorted out.



  • Hello sir i have problem as your. But how i fix " pkg-static: Cannot get an advisory lock on a database, it is locked by another process fail" . I don't understand why it show like that.


Log in to reply