Upgrading to 2.4.5 hosed my install



  • Tried to upgrade a SG-1100 via the web console to 2.4.5 from 2.4.4-p3. Could not connect after that.

    Logging in via console I was also seeing PHP errors "unable to load dynamic library 'curl.so' errors. Oddly, my Roku and Alexa could still connect to my AP unit running dd-wrt and access the internet but none of the Macbooks, iPhones or Android could connect to the internet, even though they were assigned IP addresses. A hardwired Mac could still access the net via pfSense.

    Eventually decided to reinstall everything and restore from my backup, but the memstick install (pfSense-CE-memstick-serial-2.4.5-RELEASE-p1-amd64.img.gz) fails with the error below. I also tried usb reset and that did not help. Tried two different USB sticks as well. I tried to install the OS both with the terminal commands and balenaEtcher.

    Marvell>> run usbrecovery
    ** First descriptor is NOT a primary desc on 1:1 **
    switch to partitions #0, OK
    mmc1(part 0) is current device
    MMC erase: dev # 1, block # 0, count 4194304 ... 4194304 blocks erased: OK
    reading efi/boot/bootaa64.efi
    ** Unable to read file efi/boot/bootaa64.efi **
    ** Unrecognized filesystem type **
    libfdt fdt_check_header(): FDT_ERR_BADMAGIC
    No FDT memory address configured. Please configure
    the FDT address via "fdt addr <address>" command.
    Aborting!
    No FDT memory address configured. Please configure
    the FDT address via "fdt addr <address>" command.
    Aborting!
    Starting EFI application at 05000000 ...
    WARNING: Invalid device tree, expect boot to fail
    efi_load_pe: Invalid DOS Signature
    Application terminated, r = -2
    Marvell>>



  • @jim0266-f If you're trying to reinstall with pfSense-CE-memstick-serial-2.4.5-RELEASE-p1-amd64.img.gz on an SG-1100 that will never work as it is for AMD64 architecture and the SG-1100 is ARM.

    You need to get a copy of the correct aarch64 image for the SG-1100. If you don't have one, raise a support ticket with Netgate and they'll supply a link to download. The latest version is pfSense-netgate-SG-1100-recovery-2.4.5-RELEASE-p1-aarch64.img.gz


  • LAYER 8 Global Moderator



  • Thanks!

    I've used PFsense for close to 20 years. First time I've been let down. Not thrilled not having a way to get back up and running quickly w/o having to get support involved.


  • LAYER 8 Global Moderator

    You normally will have a link to the software like 1 or 2 minutes.

    It's always a good idea to have a install media available for anything your going to be running an upgrade on. Next time just email them before hand, so you have the proper install media and on hand.

    This is really the same process for any of their appliances, since its no longer possible to download images from a "portal" that use to be there. But pretty sure you will be pleasantly surprised at how fast you get a response with link.

    btw: I think your math is a bit off ;) pfsense was forked back in 2004, and first release was 2006.. So not really possible to be "close" to 20 years.. Unless your talking you were running m0n0wall before it forked.. More like 14 years ;)



  • Thanks, I had opened a ticket before posting this. By the time you posted this there was already a response with the link. Pleasantly surprised, especially for a weekend.

    You are correct, it had to be later when I started with PFsense. Time blends... I owned a duplex back then and made a large network when I had the house rewired. I gave my tenants free internet off my connection. I first installed PFsense on a PC I found on the curb someone was throwing away. That thing ran for YEARS. Rock solid. In fact I just sold the duplex and threw out the PC that's been down in the basement unplugged for the last 10 years.

    Had to upgrade from an ALIX box last year to stay current.


  • LAYER 8 Global Moderator

    @jim0266-f said in Upgrading to 2.4.5 hosed my install:

    Time blends...

    Singing to the choir there buddy ;)

    And the older you get the faster it goes too... I was like it can't be 20 years - can it??? NFW ;) hehehe Had to double check to be sure.. And I was like whew.. Ok it hasn't been that long. heheeh


Log in to reply