Access 4G modem GUI behind pfsense over vpn



  • Hey guys, hope everyone is well and safe!

    I need access the GUI interface of a modem that provide internet to my parents home.
    My home and my parents is linked with a OPENVPN on two Pfsense router.

    From my home I can have access to every network device locate to my parents house without problem.
    I would like to manage the modem as well.... .

    The network look like:

    SITE1
    LAN : 192.168.3.1
    OpenVpn Server - VPN TUNNEL IP 10.0.8.1/24

    SITE2
    LAN: 192.168.2.1
    OpenVpn Client - VPN TUNNEL IP 10.0.8.2/24
    WAN: 192.168.5.5 (STATIC IP)
    4G MODEM: 192.168.5.1

    I did some test as well using the Pfsense PING utility. I tried to PING the 4G Modem IP 192.168.5.1:

    SITE2
    From LAN: PING Yes.
    From VPN SITE-to-SITE: PING Yes.

    SITE1
    From LAN: PING No.
    From VPN SITE-to-SITE: PING Yes.

    This is the tracert from my computer that is locate on SITE1

    C:\Users\Dell-Desk>tracert 192.168.5.1

    Tracing route to 192.168.5.1 over a maximum of 30 hops

    1 <1 ms <1 ms 2 ms 192.168.3.1
    2 286 ms 286 ms 285 ms 10.0.8.2
    3 * * * Request timed out.
    4 * * * Request timed out.
    5 * * * Request timed out.
    6 * * * Request timed out.

    Anyone can give me some help with it?

    Thanks



  • @ismurdegus Have you tried System - Routing - Static Routes?



  • Nop, I didn't.....
    If I can be honest,I am not an super expert with Pfsense

    Can you give me some help please?

    Thanks



  • @ismurdegus said in Access 4G modem GUI behind pfsense over vpn:

    If I can be honest,I am not an super expert with Pfsense

    Me either. 😆

    Maybe something like this?
    123.PNG

    Give it a try at your place (but with your VPN-Connection) and if it doesn't work, I shut my mouth.



  • This post is deleted!


  • On my system, I don't have the OPENVPN for GATEWAY

    Capture.PNG



  • Routing alone won't make it work.
    The issue is that the 4g modem only knows directly connected network, and sends everything else to internet (or nowhere).
    Create an outbound nat rule on wan intearface, with target ip the wan network.
    Use the wan interface as source.



  • I tried to follow your instruction, like I say I am not an expert....

    I create the rule on the SITE2, but is not working :-(

    Capture.PNG



  • @ismurdegus Source should be any, and certainly not 2.0
    Put at least 192.168.0.0/16 as source.

    As for routing in openvpn , it is handled via openvpn server config page, NOT static routes.
    You need sto add 192.168.5.0/24 as an ipv4 local network there.



  • @netblues

    I don't fully understand your comment, so I hope I did this right....
    On SITE2 I setup the follow but still doesn't work :-(

    Capture.PNG

    Also what you say before:
    "As for routing in openvpn , it is handled via openvpn server config page, NOT static routes.
    You need sto add 192.168.5.0/24 as an ipv4 local network there."

    This is doesn't make sense at all for me.

    Can you give me more details please?

    Thanks



  • nat rule is ok.

    As for routing, you should go to the pfsense acting as client config page
    near the bottom, tunnel settings
    IPv4 Remote network(s)

    IPv4 networks that will be routed through the tunnel, so that a site-to-site VPN can be established without manually changing the routing tables. Expressed as a comma-separated list of one or more CIDR ranges. If this is a site-to-site VPN, enter the remote LAN/s here. May be left blank for non site-to-site VPN.

    put 192.168.5.0/24 , 192.168.2.0/24 save, reestablish and retry



  • Already done this on the SITE2 (VPN Client) but still no working

    Capture1.PNG


Log in to reply