FreeRadius problem



  • Hello experts,
    I had a problem while trying to test Radius authentication on pfsense.
    what happend is actually weird because the steps I made in configuration is perfectly fine ( tried many times with many guides and tutorials ) .
    to be brief , I installed the FreeRadius package , went on and checked on services tab and it showed that Radius is working , then when I went on and a configured a basic and simple configuration ( local radius auth ) and finally tried to test authentication in diagnostics tab. what happend is that the user I made wasn't authenticated. I re-checked the services tab and what I found is that the FreeRadius service is down and It doesn't restart. I deleted the package and re-installed and still the service doesn't start. I even re-installed PfSense but it happend again.
    Can anyone please help me ? its been 2 days and I am clueless. I searched but I found nothing related to my problem. even log entries problems didn't help since what I found in google isn't related to pfsense so I didn't find any helpfull posts.
    Note : what I doubt is the package itself isn't installed correctly , please see image below!
    Capture.PNG

    any help will be much appreciated guys. thanks alot !



  • " Package is configured but not (fully) installed or deprecated "
    means that lines shown in reds are packages that are ot (fully) installed or deprecated.
    Your FreeRadius is installed and up to date, so not shown in red.
    Your issue is purely configuration.

    I advise you to stop Freeradius in the GUI?
    Open up the console (SSH access is the one to use now).
    Option 8.
    Start freeradius with :

    radiusd -X
    

    and you will see all the details. The ones printed red mean : no good.


Log in to reply