Anyone having issues with IGMP Proxy on 2.4.5-RELEASE-p1



  • Fresh bare metal install of 2.4.5-RELEASE-p1 (amd64). When I try to enable and apply IGMP Proxy under Services > IGMP Proxy, I get "There was a problem applying the changes. See the System Logs." When I check routing.log, there are no logs related to the igmp daemon and "igmpproxy" is also not listed as a service under Status > Services almost as if its completely missing.

    Re-installed on a VM as a test and I'm getting the same behaviour. Anyone else?


  • Netgate Administrator

    Not a general issue in 2.4.5p1.

    Do you have verbose logging enabled in igmpproxy?

    Is the conf file being generated? /var/etc/igmpproxy.conf

    Can you start the service from the command line? igmpproxy -dvv /var/etc/igmpproxy.conf

    Steve



  • Doesn't look like there is a config file being generated. I have enabled verbose logging from the GUI but not sure if its applied - I don't see anything in routing.log.

    2.4.5-RELEASE][admin@]/root: more /var/etc/igmpproxy.conf
    /var/etc/igmpproxy.conf: No such file or directory
    [2.4.5-RELEASE][admin@
    /root: igmpproxy -dvv /var/etc/igmpproxy.conf
    Searching for config file at '/var/etc/igmpproxy.conf'
    Unable to open configfile from /var/etc/igmpproxy.conf


  • Netgate Administrator

    Is there any error shown in the system log or dmesg when you try to save changes to it?



  • The only log entry in System Logs > System > General that coincides with hitting Apply is:

    Jul 21 10:15:34 check_reload_status Syncing firewall

    I read in the release notes for 2.4.5 that IGMP Proxy logs were moved to routing.log which is completely empty.

    Nothing abnormal in dmesg either... here are the last few lines:

    load_dn_sched dn_sched FIFO loaded
    load_dn_sched dn_sched QFQ loaded
    load_dn_sched dn_sched RR loaded
    load_dn_sched dn_sched WF2Q+ loaded
    load_dn_sched dn_sched PRIO loaded
    load_dn_sched dn_sched FQ_CODEL loaded
    load_dn_sched dn_sched FQ_PIE loaded
    load_dn_aqm dn_aqm CODEL loaded
    load_dn_aqm dn_aqm PIE loaded
    IPFW: starting up interface tracker
    [2.4.5-RELEASE][admin@**]/root:


  • Netgate Administrator

    With no config file present it should fail to start so there would be no logs in the routing log.

    But I was hoping to see an error in the system log when you save the page and it tries to create the conf file.

    You might check the drive is not full. You would see a load of errors if that was the case though.

    Steve


  • Rebel Alliance Developer Netgate

    What exactly is configured in your IGMP proxy settings on the main screen and each instance? It could be that you have made an invalid configuration which isn't detected by input validation.



  • My configuration is pretty basic. Just VLAN interfaces set as downstream so that pfsense acts as the IGMP Snooping querier for the switches. I don't actually require mcast routing. Anyways, I manually copied over the config file from a 2.4. 4-RELEASE-p3 box and started IGMP proxy from the CLI. Since then its been working fine and I can make changes from the GUI.


Log in to reply