Issue with LAGG interface MTU on 2.4.5-p1



  • just did a fresh install of 2.4.5-p1 on a brand new dell server with intel 10g (ix0 driver). when i created a LAGG LACP interface with the 2 ix0/ix1 interfaces, the interface does not show up on the interfaces list, and i cannot changed the MTU to 9000. i was able to create all the vlans i needed with the LAGG set as parent interface, but then i receive the error that the vlan cannot have greater MTU than the parent interface. all the vlan interfaces are otherwise working properly except i cannot change their MTU due to the LAGG0 interface not appearing in the list.

    i have built identical configuration in the past (older hardware, older intel 10g interfaces) but the LAGG0 shows up in the interface list and i can edit the MTU. right now i dont remember what version the original install of this older config was, but its current version was 2.4.4-p3. actually i took its duplicate system and upgraded from 2.4.4-p3 to 2.4.5-p1 and the LAGG0 interface still appears on the list.

    im not sure if this is something that should be submitted as a bug? has anyone else experienced this issue with a new install of 2.4.5 yet?


  • Netgate Administrator

    Hmm, I've not been able to replicate that.

    I assume you still see lagg0 in the ifconfig output?

    It just doesn't show in the list or available interfaces to assign?

    Steve



  • it actually does show up with ifconfig -a, but it does not appear in the interfaces drop down.


  • Netgate Administrator

    Can we see the ifconfig output? It must be presenting in some odd way for the gui to exclude it.

    Steve



  • it actually looks normal to me. i can post it later, but ill have to do extensive redacts.

    interestingly, the upgrade pre-2.4.5 one has this entry in its backup xml:

    	<opt3>
    		<descr><![CDATA[LAGG0]]></descr>
    		<if>lagg0</if>
    		<enable></enable>
    		<spoofmac></spoofmac>
    		<mtu>9000</mtu>
    	</opt3>
    

    and the new fresh install of 2.4.5 does not, but it does have all sub-interfaces for all the vlans, like this:

    	<opt1>
    		<descr><![CDATA[VLAN_130]]></descr>
    		<if>lagg0.130</if>
    		<enable></enable>
    		<spoofmac></spoofmac>
    		<ipaddr>redacted</ipaddr>
    		<subnet>24</subnet>
    	</opt1>

Log in to reply