After failover, delay recovery



  • When there is a failure, I'd like to switch to back-up as quickly as possible. But when the primary WAN recovers from failure, is there a way to delay the gateway group from switching back to the primary WAN immediately?

    Seems that when we have a failure, it comes and goes for awhile before stabilzing.



  • What is your monitor IP?

    I think you will have to play around with the gateway settings. Go to System > Routing > Gateway. Expand the advanced settings at the bottom of the page. It kind of depends on the issues you typically see with your network. For example, if your primary gateway is marked down due to a lot of packet loss, then the packet loss setting is what you should adjust. Likewise, if the issue is latency, then adjust the latency threshold.

    For example, if your problem is packet loss, then lowering the default packet loss threshold values would switch to the secondary network more quickly and take longer to switch back to the primary network. Try 5/10 to start and see if it helps? Start with something simple like that but if that doesn't help you might have to change other settings like maybe increasing the time period from (60000) 1 minute to 2 minutes. I wouldn't do that unless it's really necessary.



  • I'm using the default IP.

    I guess the issue is that I'm normally gettting about 20-25ms of latency. That seems to be OK, but if it jumps much higher then we start having VoIP issues. I've started tuning the latency threshold down, as you suggested. But, I can't go much lower or it never switches back to primary.

    My concern with adjusting the time period was that I thought it affected both switching into and out of the backup wan. So, increasing the time period would delay the switch to back-up. That may still be my best options still: lower the latency threshold and increase the time period.

    Thank you



  • @Ximulate said in After failover, delay recovery:

    I'm using the default IP.

    I guess the issue is that I'm normally gettting about 20-25ms of latency. That seems to be OK, but if it jumps much higher then we start having VoIP issues. I've started tuning the latency threshold down, as you suggested. But, I can't go much lower or it never switches back to primary.

    My concern with adjusting the time period was that I thought it affected both switching into and out of the backup wan. So, increasing the time period would delay the switch to back-up. That may still be my best options still: lower the latency threshold and increase the time period.

    Thank you

    Yes, it is a little more complicated with latency affecting VOIP. That's right, increasing the time period would impact the overall average of the gateway monitoring numbers. I would expect increasing time period would take longer to switch to secondary and longer to switch back to primary, but it would smooth out any "bumpiness" in latency if it takes time for the gateway to stabilize.



  • @Ximulate said in After failover, delay recovery:

    I'm using the default IP.

    Some may not agree, but try another IP. I have had luck with 8.8.8.8 (Google DNS). I don't think it will solve this issue since it sounds like you have actual latency impacting you.
    Edit, On second thought, leave it alone. Particularly since you will be lowering the threshold, using 8.8.8.8 may have moments of latency and packet loss that will be normal and your lower values will make matters worse.


Log in to reply