Not able to get WAN from xfinity



  • Running pfsense on Hyper-v Server. Was working fine on Comcast Business account and SB8200. Two weeks ago I switched to xfinity residential account and when I had the account activated, I was not able to get a WAN IP from xfinity. They insisted on a truck roll but the guy was not able to do anything other than sign me up for a xfinity modem to replace my new SB8200.
    I have a Netgear Router on dd-wrt that can connect. When I connect my pfsense to the modem I get this in the logs when I renew the DHCP on the WAN. Hyper-v server has an Intel Pro 1000 PT Dual Port Server Adapter for WAN and LAN connections. Any ideas?
    Am unable to include logs as the spam filter keeps blocking me.

    Jul 18 12:39:59 dhclient FAIL
    Jul 18 12:39:59 dhclient 41817 No working leases in persistent database - sleeping.
    Jul 18 12:39:59 dhclient Deleting old routes
    Jul 18 12:39:58 dhclient New Routers (hn0): 67.160.96.1
    Jul 18 12:39:56 dhclient New Routers (hn0): 67.160.96.1
    Jul 18 12:39:56 dhclient New Broadcast Address (hn0): 255.255.255.255
    Jul 18 12:39:56 dhclient New Subnet Mask (hn0): 255.255.252.0
    Jul 18 12:39:56 dhclient New IP Address (hn0): 67.160.99.151
    Jul 18 12:39:56 dhclient ifconfig hn0 inet 67.160.99.151 netmask 255.255.252.0 broadcast 255.255.255.255
    Jul 18 12:39:56 dhclient Starting add_new_address()
    Jul 18 12:39:56 dhclient TIMEOUT
    Jul 18 12:39:56 dhclient 41817 Trying recorded lease 67.160.99.151
    Jul 18 12:39:56 dhclient 41817 No DHCPOFFERS received.
    Jul 18 12:39:44 dhclient 41817 DHCPDISCOVER on hn0 to 255.255.255.255 port 67 interval 12
    Jul 18 12:39:19 dhclient 41817 DHCPDISCOVER on hn0 to 255.255.255.255 port 67 interval 25
    Jul 18 12:38:55 dhclient 41817 DHCPDISCOVER on hn0 to 255.255.255.255 port 67 interval 24
    and this

    Jul 18 12:38:26 dhclient exiting.
    Jul 18 12:38:26 dhclient process and the information we find helpful for debugging.
    Jul 18 12:38:26 dhclient before submitting a bug. These pages explain the proper
    Jul 18 12:38:26 dhclient bugs on either our web page at www.isc.org or in the README file
    Jul 18 12:38:26 dhclient than a configuration issue please read the section on submitting
    Jul 18 12:38:26 dhclient If you think you have received this message due to a bug rather
    Jul 18 12:38:26 dhclient Can’t attach interface {} to bpf device /dev/bpf0: Device not configured
    Jul 18 12:38:26 dhclient Sending on BPF/hn0/00:15:5d:00:91:03
    Jul 18 12:38:26 dhclient Listening on BPF/hn0/00:15:5d:00:91:03
    Jul 18 12:38:26 dhclient For info, please visit https://www.isc.org/software/dhcp/
    Jul 18 12:38:26 dhclient All rights reserved.
    Jul 18 12:38:26 dhclient Copyright 2004-2018 Internet Systems Consortium.
    Jul 18 12:38:26 dhclient Internet Systems Consortium DHCP Client 4.4.1

    Tested OPNSense and it was able to get an IP using the same NIC.



  • About the issue :
    So you're using a modem now ?
    Is DHCP the WAN type of interface ? Could it be PPPOE ? This kind of info is what the ISP should tell you.

    "67.160.96.1" is a valid WAN IP, although it exists on some major DNSBL's - see your other messages.

    Btw : As far as I know, the dhcp client used by pfSense (from ISC) and the one use by OnOsense is the same.

    As you can see, it pushed out DHCPDISCOVER requests.
    If there was a DHCP server (your ISP is running one) listening and reachable, it should answer with an DHCPOFFER.

    @Rogero54 said in Not able to get WAN from xfinity:

    Am unable to include logs as the spam filter keeps blocking me.

    Use the good old pastebin.com



  • So I am currently using the SB8200 modem. It is xfinity and they use DHCP. The current router is a Netgear WNDR3700. Confirmed that it is set to DHCP for WAN and it is able to get an IP. Current WAN ip is 71.227.x.x. Have been removing the Netgear and plugging in pfsense several times a day troubleshooting and the Netgear alwas gets an IP. Have used the Netgear MAC and spoofed it in pfsense to no avail. Later today I am going to try one of the onboard NIC's to see if that makes any difference.
    One thing I did notice about OPNSense is that it did take along time to finally get an IP address from Xfinity. This modem and pfsense VM was working perfectly on COmcast business account I had. PFSense was working for awhile on the xfinity modem but I wanted to use the one I just bought and switched back to the SB8200.


  • LAYER 8 Netgate

    Are you power-cycling the modem when you change the WAN port behind it?



  • Yes. For additional information, I just set up the onboard NIC with the MAC of the Netgear router and swapped them. Pfsence was able to get a WAN IP but I could not get out to the internet. Was pinging various IP's from the pfsense console (not UI) and could get to the xfinity default gateway, but not to DNS servers 9.9.9.9 or 8.8.8.8. Did a factory reset of pfsense and then could not get a new WAN IP again. So, back to dd-wrt until the wife leaves then I can see if OPNSense can actually connect and pass traffic. Assume many people are running pfsense on hyper-v given the installed base of users for it.



  • Try this :

    Remove the pfSense WAN cable.
    Reboot the modem, and have it start up for a minute or two, three, the time it needs to stabilize. Then put back in the pfSense WAN cable.

    What might happen is, that when you reboot the modem, it 'LAN' side goes down, pfSense detects - the DHCP client on WAN - this and it starts to send out DISCOVERS. The modem boot time is far to long, and dhcp will go into 'fail' mode.
    There are options - see the DHCP Client Configuration on the WAN interface section, check Advanced Configuration, to have the DHCP client delay a bit after a WAN UP event.

    DNS servers 9.9.9.9 or 8.8.8.8.

    You don't need these, except if you have to communicate Google all your DNS requests. The pfSEnse default DNS settings work fine.



  • Had some time yesterday to play with this again. Tried shutting down xfinity modem for a few hours. Turned it back on and waited 30 minutes before plugging in pfsense. Still no IP. Repeated same steps with wait times and used opnsence instead, same result. Also tried switching network cards from on board to intel pro1000 PCI and didn't make any difference. Plugged netgear router back in and it worked after a modem reboot.
    Leads me to believe that it is a Hyper-v thing.


  • LAYER 8 Netgate

    I would put a "smart" switch between the WAN interface and the modem and monitor the traffic on the port connected to the modem and mirror it to a laptop running wireshark and see what it thinks about the DHCP being exchanged.


Log in to reply