Ldap module for php?



  • Hi,

    on my pfsense installation, the php does not have an ldap module.

    Has this a specific reason?
    would it be a design or security break to install one?
    Some hints on how to install one?

    Thanks,

    Jean-Marie.

    PS: pfsense 1.2.2 built on Thu Jan 8 22:30:24 EST 2009

    
    > /usr/local/bin/php -v
    PHP 4.4.9 with Suhosin-Patch 0.9.6 (cgi-fcgi) (built: Nov  9 2008 20:28:06)
    Copyright (c) 1997-2008 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    
    
    
    > /usr/local/bin/php -m
    [php]
    apc
    bcmath
    ctype
    curl
    mbstring
    openssl
    overload
    pcntl
    pcre
    posix
    radius
    readline
    session
    standard
    tokenizer
    xml
    
    [Zend Modules]
    
    [/php]
    


  • It's not included in the 1.2.* branch because it was unneeded.  The beginning of ldap integration are in pfSense 2.0.



  • Hi,

    is there a possibility that I install one on my 1.2 Version? or is this too much hassle?

    Jean-Marie.



  • Not supported and not possible without rolling your own pfSense so also not recommended.


Locked