VirtualBox Host No Internet when using pfsense as gateway



  • Hi Guys Good Day. I need help configuring pfSense using VirtualBox for Lab purposes. The connection is via Bridged mode using Oracle Virtual Box. Flow is like this Telco Modem --> DLink Router as a switch 10.10.10.1 --> Virtual Host --> pfsense 2.2.2.1 . My Virtual Host (Laptop) using the same IP subnet of pfsense LAN side which is 2.2.2.2, also my Virtual Host (Laptop) is using the pfsense LAN side as the gateway which is 2.2.2.1 . The problem is I can't get to the wan side when I ping from LAN as source diagnostics. Rules to permit any to any is already in place but still no luck connecting my virtual host to the internet.

    Appreciate the help guys, TIA.


  • Netgate Administrator

    What exactly are you pinging?

    You should always be able to ping between pfSense's own IPs, so from the LAN IP to the WAN IP should work.

    If you're pinging the switch it should work as long as the outbound NAT rules are correct. They should be unless you have switched them from automatic or you do not have a gateway on the WAN interface.

    Check the state table (Diag > States) when you're pinging. You should see the outgoing ping state NAT'd to the WAN IP.

    Steve



  • Hi Steve thanks for the prompt reply, I'm trying to ping anything outside the WAN side of pfsense (8.8.8.8). Thanks for the help, I tried to enforce the NAT again, this was disabled since I thought it will cause an error because of double NAT (DLink Router and pfsense). Now I can go to the internet using my host connected to pfsense. Unfortunately I encountered a new problem when I access the Package Manager --> Available Packages. At first, I can see a list of packages, then I tried to install squidguard, unfortunately, it failed to install the said package. When I tried to access again the Available Packages a problem occurs saying "Unable to retrieve the package information" now I'm stuck :(

    BTW I'm using 2.4.5_p1


  • Netgate Administrator

    Yeah, you need NAT to reach anything from an internal non-routable IP as you found.

    Try running at the command line: pkg -d update
    What error does it report?

    Steve


Log in to reply