Unable to change Serial GPS baud rate



  • I've configured this successfully before, but on a relatively fresh install I'm trying to do it again with a new GPS receiver for this build. I can't seem to get the baud rate to switch to anything other than 4800 in the Serial GPS options. The GPS I am using has a baud rate of 9600. Has anyone seen this issue before? Would initially seem like possibly permissions related, but I can change the GPS receiver type and that successfully stays, so I'm unsure here.


  • Netgate Administrator

    Yes I've seen similar behaviour to that before. If I recall correctly it was because you need to initialise the receiver in it's native baud rate to then use whatever speed you set.
    Are you initialising it at 4800 in one of the default settings?

    What are you seeing? What have you set? How are you testing?

    Steve



  • Previously, I've just used a USB GPS, so this straight RS-232 serial GPS with PPS is new for me. I was just using the "Generic" settings and also tried "Custom" but none keeps the baud rate selection.

    If I remove the serial cable and connect it up to a different machine, I can see the messages coming through just fine, so I know it's working.

    Here are the settings I am attempting, minus the baud rate being correct.

    2936c007-cedb-4823-b563-892de6536d38-image.png


  • Netgate Administrator

    Nothing in the advanced settings?

    Hmm, I remember hitting this and it was some chicken and egg style setting issue... 🤔



  • @stephenw10 Nope, nothing in the advanced settings. The gps starts streaming messages immediately upon powering up and achieving the lock, so shouldn't be anything necessary in there (from what I can tell).

    Such a weird issue. Thanks for your help. I'll look at it more today as well and see if I can poke around.


  • Netgate Administrator

    Hmm, looks like a bug: https://forum.netgate.com/topic/152369/ntp-gps-settings-serial-port-speed

    That's fixed in 2.5.

    It is possible to set 9600 in 2.4.5p1 though, I have that running here.

    Try stopping the ntpd service then making the change.

    Steve



  • Interesting, thanks for the pointer. I will try and let you know how it goes.



  • Stopping the service did not allow for the baud rate change. I'll update to 2.4.5_1 and see how it goes then.



  • I updated to 2.4.5_1 and am still unable to change baud rate. Everything else on that page can be changed except for the baud rate. Stopped the service and tried again post update, but still no dice.


  • Netgate Administrator

    Hmm, it's in 2.5 dev snapshots if you're able to run those.

    Otherwise I would check the baud rate being set in the config file and what speed the actual device comes up at. It could just be a display bug.

    Steve



  • I updated to 2.5 dev and nuked everything (no connectivity on any of the VLANs) so I've reinstalled 2.4.5_1 and reverted my config. I will try again with the GPS later. Thanks again for your help thus far with troubleshooting.



  • Also worth noting is that you were correct - before I reverted my config because all routing was broken and I had no connectivity except on my fallback OPT1 HW interface, I did check the GPS settings and was able to change to 9600. On 2.5x with the baud rate able to be changed, the GPS immediately started working and had a lock, with PPS working and all was well.


Log in to reply