Crash config after VirtualIP set



  • I have config based on filtered bridge & shaping
    1.5 month all good worked. Yestady i add one carp Virtual IP (one IP be exists and no any problem)
    After apply i have problem - manyyy messages
    'Warning in _array(): wrong datatype for second argument in /etc/inc/config.inc on line 1409"

    After 1.5 h pfsense stop sturtup :)



  • 1 h later

    pfSense end rebooting.
    I in shell assign IP on interface. restart WebGui. connect WebInterface and download config.
    delete Virtual IP. set off CARPenabled
    After uploud config and reboot i see 'Cleaning backup cache' - clear backup cache dir
    Line 1409 - this function



  • CARP doesn't work for bridged interfaces.



  • i not need use CARP
    this options be as ON. I set this off …

    But my problem not with this
    Problem with biggest count backup config files
    Procedure
    function cleanup_backupcache($revisions = 30)
    in /etc/inc/config.inc work 1.5h and nothing delete
    I manually clear '/conf/backup' with 'rm -f /conf/backup/conf*'
    After this reboot = 1.25 min and all my rules apply success
    May be set count cycles in this function to 100-200
    After each reboot they smallest delete backuped old configs - wite 1.5h ... - hard time.



  • Solved with cleare /conf/backup
    Problem not VirtualIP
    Problem with function 'cleanup_backupcache($revisions = 30) '



  • No, problem is your running an older version.  Upgrade to a testing snapshot.



  • ОК
    But may be after update make full empty '/conf/backup' ?
    I calculate 1750 backup files - first dated as Beta1 age.



  • Reinstall.


Locked