pimd - doesn't appear to work



  • I want to just have any any traffic between my internal network segments.
    The pfSense box is running on vmware and the down stream switch doesn't have any IGMP config so in theory all multicast traffic should be been broadcast to all switch ports in the same vlan. I want pfSense to then forward all IGMP traffic to any receiver on any other vlan.

    I have IGMP proxy disabled and PIMD enabled

    I don't ever seem to have an entry in the Multicast routing table:

    Virtual Interface Table ======================================================
    Vif  Local Address    Subnet              Thresh  Flags      Neighbors
    ---  ---------------  ------------------  ------  ---------  -----------------
      0  10.28.1.254      10.28/16                 1  DISABLED
      1  10.22.1.254      10.22/16                 1  DR NO-NBR
      2  10.27.1.254      10.27/16                 1  DR NO-NBR
      3  10.23.1.254      10.23/16                 1  DISABLED
      4  10.24.1.254      10.24/16                 1  DISABLED
      5  10.26.1.254      10.26/16                 1  DR NO-NBR
      6  10.22.1.254      register_vif0            1 
    
     Vif  SSM Group        Sources             
    
    Multicast Routing Table ======================================================
    --------------------------------- (*,*,G) ------------------------------------
    Number of Groups: 0
    Number of Cache MIRRORs: 0
    ------------------------------------------------------------------------------
    
    


  • Hi @kmarston

    Have you tried enabling "Allow IP Options" on the network segments you wish to pass multicast traffic between?

    https://docs.netgate.com/pfsense/en/latest/book/firewall/troubleshooting-firewall-rules.html#review-rule-parameters

    Also, after making PIMD configuration changes, you may need to clear (reset) your firewall states as well for them to properly go into effect.

    Hope this helps.


Log in to reply