Can't start Resolver nor make configuration changes


  • I had to shout down my pfsense box. When I restarted it I could not find anything on the net. I looked and saw that unbound was not restarted. I have tried multiple times to restart it manually but it will not start. I have tried rebooting the router and it still won't restart. When I restart the service I get the follow in the System Logs/Resolver

    Aug 18 11:39:19 	unbound 	52130:0 	debug: duplicate acl address ignored.
    Aug 18 11:39:19 	unbound 	52130:0 	debug: drop user privileges, run as unbound
    Aug 18 11:39:19 	unbound 	52130:0 	debug: chroot to /var/unbound
    Aug 18 11:39:19 	unbound 	52130:0 	debug: chdir to /var/unbound
    

    I also noticed that in the resolver setting the SSL/TLS Certificate listed is expired. So i went to change it to the new certificate but when I try save the changes they do not save and I get the following errors:

    The generated config file cannot be parsed by unbound. Please correct the following errors:
        [1597764046] unbound-checkconf[39086:0] error: local-data in redirect zone must reside at top of zone, not at yts.moatads.com 60 IN A 10.10.10.1
        [1597764046] unbound-checkconf[39086:0] fatal error: failed local-zone, local-data configuration
    

    I'm running pfSense 2.4.4-RELEASE-p3 (amd64)

    Thanks for any help in getting this fixed.