SG-1100 LTE USB-Modem



  • Hi,

    is anyone successfully running a USB modem on an sg-1100? I'm currently trying to get my Huawei E3372h-320 working, but I can't even get to the point where I could assign it to any kind of interface. It doesn't stay connected on the USB level:

    ugen0.2: <HUAWEIMOBILE HUAWEIMOBILE> at usbus0
    ugen0.2: <HUAWEIMOBILE HUAWEIMOBILE> at usbus0 (disconnected)
    random: unblocking device.
    ugen0.2: <HUAWEIMOBILE HUAWEIMOBILE> at usbus0
    cdce0 on uhub0
    cdce0: <CDC Ethernet Control Model ECM> on usbus0
    ue0: <USB Ethernet> on cdce0
    ue0: ugen0.2: <HUAWEIMOBILE HUAWEIMOBILE> at usbus0 (disconnected)
    Ethernet address: 00:1e:10:1f:00:00
    cdce0: at uhub0, port 2, addr 1 (disconnected)
    cdce0: detached
    ugen0.2: <HUAWEIMOBILE HUAWEIMOBILE> at usbus0
    ugen0.2: <HUAWEIMOBILE HUAWEIMOBILE> at usbus0 (disconnected)
    

    I thought it might just not get enough power, but according to the LED on the stick it boots up successfully and even connects to the mobile network.
    Any ideas what might be at play here? The stick works just fine under Windows.

    Thanks
    Max


  • Netgate Administrator

    Does it work correctly in a different device?

    Does it behave any differently in the two USB ports?

    Steve



  • It works fine on multiple windows machines, I haven't gotten around to trying it with pfsense (or any linux/FreeBSD in general) on different hardware yet.
    I tried both ports, exactly the same results.



  • Just tried it with pfsense running in a vmware vm and the stick passed through to it. Same results as with the sg-1100. I then tested with an ubuntu 20 vm and the stick passed through. That worked without issue.



  • I did one more test with a pfsense 2.5 snapshot (pfSense-CE-2.5.0-DEVELOPMENT-amd64-20200816-0050). The stick works without issue there. My guess is FreeBSD 11 is either missing drivers, or has broken drivers for the sticks chip.


  • Netgate Administrator

    Hmm, it could well be missing something in FreeBSD 11 that is present in 12.

    Does it appear the same way? Still creates a ue0 interface?

    Steve



  • yes, under 12 it still creates the ue0 interface


Log in to reply