• Not sure if this goes here or in the L2 section, my apologizes.

    TL;DR LAG not working(ish) on MB8600 to PFSense WAN.

    I recently got the Motorola (Zoom) MB8600 cable modem with the sole purpose of being able to LAG port 1 and 2 attached to my PF box.

    I was able to get the LAG to work (sorta) with some notable exceptions. Here is where I need help. With the LAG setup I am maxing out at 760 Mbps from the PF box to the interwebs. With LAG turned off over 1 cable I am able to get 928 Mbps (don’t care about upload).

    So I started to do some testing. I have attached a link to a quick diagram to hopefully help everyone understand how I have it setup. https://imgur.com/gallery/3DIPnKH 2

    First, I tried to determine if possibly one of the cables was bad. When I unplugged port 1 going from the modem to the router everything seem to work ok. The connection stated alive but the speed did not increase. I plugged port 1 back in and did the same thing with port 2. Very interesting result, no connection. PF was not able to pull an IP address. I changed out the cable and had to same issue. Ran diagnostics on modem and the port is fine (also same port that is used when LAG is turned off).

    To double check that the port was ok I turned off LAG and removed the LAG interface from PF and switched over the WAN to one of my Intel NIC ports. Tested everything. Worked just fine with speedtest coming back with 928 Mbps.

    Why would I get capped out at 760 Mpbs with PF when I was able to find others out there with Linksys and ASUS getting 1.1+ Gbps (Due to over provisioning). Right now I would be happy to LAG working with 940 Mbps. I am not thinking that LAG is magical and will get me some crazy more bandwidth. I started this because I wanted to experiment with LAG and now I am just at a loss. Please help! TIA