List of available packages is not showed


  • Hello.

    List of available packages is not showed e even when I search there are no results. Any idea?

    6061d8b7-fb1b-45b3-a739-d86d9f095a93-image.png


  • Hi,

    Very know issue.
    Most common issue issue : your WAN interface is not connected. PfSense can't go out and grab the list from the pfSense package servers.
    Normally, after a fresh install of pfSense, LAN is up, and WAN is up. If at this time the package list doesn't populate, you will know that your connection is filtered. The issue isn't pfSense, but you, choosing your "Internet Provider".

    Or : the package list populated ones, in the past,when the instaltion was just activated, but it doesn't do so any more.
    The most common issue is now : the pfSense admin made some DNS changes, and 'broke' DNS resolving for the router pfSense itself while doing so. The URL of the pfSense package site can't be resolved any more - as a matter of fact, pfSense can't resolve nothing any more : no more NTP neither, no more monthly bogons list download, no more update checks. This could happens rather unnoticed, as DNS resolving for the LAN still works - LAN devices can resolve just fine (the admin would have noticed that his DNS changes were wrong right away).

    What also can happen : See https://docs.netgate.com/pfsense/en/latest/packages/fixing-a-broken-pkg-database.html

    Edit : see also https://docs.netgate.com/pfsense/en/latest/install/upgrade-troubleshooting.html


  • @Gertjan Thank you for your answer.

    The issue is solved.

    There are two WANs in my pfSense and they were toghether in a Gateway Group and this GG seted as de Default Gateway.

    Then I changed the Default Gateway to one of the WANs e and seted priority "Never" in Gateway group for the another WAN.

    I restarted the NTPD service.

    Now I am no sure about what of these solved the problem.

    Based on your answer I supose changing Default Gateway was the solution.