(No) Available Packages



  • I'm looking to setup local VPN instance on my pfSense installation. To allow me download user certificate/config files, i need to install open VPN client export however, the lost of available packages in package manager is empty.

    Is this a general issue or are there steps I can carry out to fix this?



  • Hi,

    Yeah, we know, this behaviour can be seen every week or so on the forum.
    That is, the pfSense package servers work just fine, the actual issue is that people after an initial working setup, break the internet access for pfSense itself. This can go unnoticed, as LAN to Internet still works. Thus, your issue is most probably a setup issue. Like : you briked DNS access.
    pfSense can't check for updates anymore, neither list the packes etc.

    Test it out for yourself : reset to default settings and see that "it works again'.

    Btw : right now, the package servers works just fine, as the list on my pfSense populates.



  • You said :

    ..... unfortunately resetting all configuration would not be possible

    Their is always something as a "backup".
    Make one here Diagnostics > Backup & Restore > Backup & Restore .
    Your system will die sometime. No need to re set it up again : just install pfSEnse on a new system, import the backup and ... Done.
    Backup con be imported back in again. With two clicks you set up the entire pfSense system as it was before.

    So, you can always go to "default". You should even try it ones, so you know what needs to be done when 'panic moment arrives'.
    It will take .... 10 minutes ? If you have 10 left some where. If not, you have an even bigger issue.

    The default install, with only WAN configured - and most often default WAN config = DHCP will work just fine - will exclude a whole lot of issues.

    It works : it's your DNS setup. You changed something, most often without knowing what DNS is / how it works, whatever. Take note of the DNS settings, import your backup back in, and then redo the DNS as it was 'by default' => issue solved.
    It still doesn't work : your issue is upstream and not pfSense related.



  • @Gertjan Thanks.

    Will look through the DNS configuration to see what could have been set wrongly and keep the reset as a last resort.



  • Also do some checks using these : pfsense manual package maintenance


Log in to reply