SG-3100 Internet Throughput Issue



  • [Cross-posted on reddit.com/r/PFSENSE]

    I'm a long-time pfsense user. Originally, I used a Soekris box. As my cable internet speeds have increased over time, I outgrew the 100Mbps ports on the Soekris box and upgraded to an SG-3100. Until recently, I had Spectrum 200/10Mbps (down/up) internet that would regularly test out (via various speedtest.net servers) at 220+/12+. More recently, the download speed was less, but I didn't think too much of it.

    I'd been toying with the idea of upgrading to Spectrum Ultra, mainly for the increased upload speed to support our new Covid-19 work/learn from home lifestyle that often involves multiple simultaneous video chats. I proceeded with that upgrade about a week ago. Spectrum needed to send me a new modem since they indicated my current modem was not capable of more than 300Mbps. The modem arrived earlier this week, and I swapped it into service.

    Upon activation, I immediately ran a few speed tests with various speedtest.net servers. Upload speeds increased to 20-25 Mbps, as expected. My download speeds, however, varied from about 30Mpbs to 130Mbps, oftentimes peaking early in the test and then decreasing as the test progressed. Nowhere near the 400Mbps advertised. I started to think that something might have been wrong even before I upgraded.

    Since then, I've performed extensive troubleshooting, and am fairly certain something either with the SG-3100 or pfsense itself is the problem. Here's what I've done:

    I run modern Ubiquiti WIFI hardware, which hadn't been a bottleneck with the previous 200/10 speed tests. Nevertheless, I tried disabling Wifi on my laptop and connecting directly to a LAN port on the SG-3100 with an Ethernet cable (all other LAN and OPT connections removed so only my laptop was on the network). No improvement in speed test results.

    Reboot SG-3100. No improvement.

    Connect laptop directly to Spectrum modem. Get ~ 500/25. Woah...Now I'm not suspecting Spectrum is the problem. Start googling.

    Check speed and duplex on WAN interface of SG-3100. No issue.

    Try a different Ethernet cable between modem and SG-3100. No improvement.

    Try using the same MAC address on the WAN interface of the SG-3100 as my laptop Ethernet port so that I get the same IP address on the SG-3100 as my laptop. Confirmed the same IP issued. No improvement.

    Backed up pfsense settings. Reset SG-3100 to factory defaults. Did NOT restore settings. No improvement.

    Contacted pfsense support to get the SG-3100 image. Re-flahsed SG-3100 with factory image and default settings. No improvement. Note I was using version 2.4.5-p1 before reflashing, and that is the version provided by pfsense support that I reflashed to.

    Got brave and upgraded to the dev firmware version 2.5.x. No improvement.

    All the while, searching google, reviewing hardware specs, etc. Seeing a number of results that say that the box should support near 1Gbps throughput.

    I've run out of ideas and am looking for any help the community can provide.

    Thanks.

    M


  • Netgate Administrator

    Mmm, it should be able to pass that in a speedtest no problem.

    What sort of WAN connection is it?

    Are you passing the public IP directly to pfSense?

    Are there any errors shown on the WAN in Status > Interfaces?

    Steve



  • Is PowreD enabled?


  • Netgate Administrator

    powerd should not make any significant difference here. There is no cpufreq driver for the Marvell 88F6820, it cannot change the running frequency.

    Steve


Log in to reply