HELP Internet is out AT&T Uverse



  • Hello,

    I have a weird situation after rebooting an AT&T NVG589 and pfsense router. I have no Internet access but can connect to my Nextcloud server from my phone on my network. I shutdown both to replace a battery in my battery backup system. Nothing changed at all with the configuration.

    On the AT&T modem, all firewall functions are turned off, and I have IP Passthrough selected. My passthrough mode is DHCPS-fixed, and the pfsense wan mac address is used for the fixed MAC address passthrough. I know it is working because my WAN interface on pfsense has my AT&T IP address. pfSense is doing DNS routing.

    I am unable to get to a website when connected to my network (cable, wifi). But as I said above, I can get to my Nextcloud instance which is going through a reverse proxy with a rule setup in pfSense.

    I have pfblockerng running. I disabled it to see if it was the issue, and it did not change anyting.

    What would have caused this issue to occur just from rebooting? What can I do to get my Internet back?


  • Netgate Administrator

    No or wrong default route would be my guess. Inbound connections work because reply-to gives it a route back.

    Go to System > Routing > Gateways. Make sure WAN is set as the default IPv4 gateway rather than auto. Save and apply, check the routing table in Diag > Routes.

    Your WAN gateway was down at one point and the auto setting chose a different gateway to use as default.

    Unless you're running pfatt in which case anything could have happened. 😉

    Steve



  • The default gateway was set to wan not auto. I run a backup of pfsense on unraid as a VM. I booted into that, and it was working. It has an older configuration file without pfblockerng, but that shouldn't matter. I tried to use that configuration on my broken instance, and no luck. I replaced the lan cable just to eliminate that possibility, and it was not an issue. I can log into my AT&T gateway and pfsense. But I cannot log into my unraid server which is on my private network managed by pfsesne. However, when I use my iphone as a hotspot I can connect to unraid. It only lets me connect on my internal network, so why is a connection through my phone on at&t allowing me to connect?


  • Netgate Administrator

    That sure seems like a routing issue as I outlined above.

    What does the route table show?

    Steve



  • I'm using my backup pfsense right now and will have to check the routes on the broken instance this weekend as it ate up my day yesterday. But I do have a question around that. How could it be a routing issue on a brand new installation of pfsense restored with a working config file? Both my VM pfsense (backup) and bare metal pfsense have used each other's backup files since I started using pfsense. The both have Intel 4 port NIC's and number of processors, and the only difference is RAM. That doesn't make sense that the routes would work on one and fail on another. When I do get the time, I would like to compare the routes on both. Correct me if I am wrong, but that would be routes under the diagnostics tab? Also would it be possible that pfblockerng all of a sudden crapped on on a reboot (starting the problem)?


  • Netgate Administrator

    Almost impossible to say without seeing the routing table. You might have something tied to a MAC address maybe?

    The fact inbound connections work and outbound don't can really only be a firewall rule on the internal interface, a routing issue or no outbound NAT rule for internal clients.

    Hard to say why that would be any different between the two instances.

    Steve


Log in to reply