Local DNS Not Resolving



  • I have a strange problem. I recently moved my local DNS server to my PFSense router. Resolving external things works fine. I have most of my local machines on static mappings and I have the "Register DHCP static mappings in the DNS Resolver" checked.

    The problem is non of my local hostnames are being resolved as in I can't get to them in the browser as I could when I was using my other internal DNS server. The strange thing is I can do a nslookup and it finds the resolved ip.

    Any idea what I am missing?



  • Try it together with the Domain in System / General Setup, e.g. .localdomain



  • That is already set to my local domain.



  • Is your browser using DNS-over-HTTPS (DoH)?



  • @teamits said in Local DNS Not Resolving:

    Is your browser using DNS-over-HTTPS (DoH)?

    Using some destination IP, using some destination port , so it will flow right through pfSense, with a nice advantage : DNS will nearly always just work without any user interaction needed.
    pfSense can't even see the traffic as it is TLS point to point - and the MITM-DNS has been invented yet.

    or : pfSense is set up as a DoH server, using it's port 853 set up on LANB, and the browsers and any other service on any device on LAN is set up to use DoH instead of the classic DNS : in that case @Lrayh82 would be an DNS expert. DNS experts do not tend to have DNS problems ^^
    Btw : DoH over your own local network : some severe degree of being paranoid is needed.

    @Lrayh82 said in Local DNS Not Resolving:

    I have a strange problem

    The (a) solution is simple : when you installed pfSEnse, DNS was working just perfect. As it works out of the box. If issues exist right after installing pfSense,n your DNS issues are up stream.
    So : easy : set your DNS settings back to the default ones, and you'll be fine.

    @Lrayh82 said in Local DNS Not Resolving:

    the "Register DHCP static mappings in the DNS Resolver" checked.

    This is default setting . As said above : : it's a part of the perfect DNS plan ^^

    This might be the exception :
    efd0a1d5-323b-4643-91e8-1d990f8bbfb3-image.png

    There are reasons to disable this option.

    If you set up your pfSense like this :

    8c46d25e-9b2f-4f88-a9f6-4654e339ee81-image.png

    then you can access the GUI it like this :

    https://pfsense.your-network.tld
    

    ( if you use the default https 443 port)


Log in to reply