1 ISP 2 Nics 1 remote ARP

  • My ISP has max badnwidth of 100Mbps, I have taken 2 connections from same ISP (not possible to have 2 different since no other service provider)

    I am trying to use multiwan but problem is that ISP is using same DHCP hardware for 2 different networks, as a result pfsense gets into a fritz of errors
    arpresolve: can't allocate llinfo

    since the arp gets registered with slower connection and the faster connection just keeps losing the IP with above error.

    Also my ISP gives a DHCP lease of 3 days 10 minutes but pfsense keeps refreshing the IP every 60 seconds. that's another reason for above error.

  • Not sure exactly what you're trying to accomplish. Multiwan will need 2 different providers. Unless you want to do some sort of lab testing. You have 1 ISP and only a 100Mbps connection. 1 WAN interface will easily handle that. I think you may be confusing multiwan as a feature to make 2 different internal networks. that's not what multiwan is. You may want to look into setting up 2 nics as separate LANs. You can then have pfsense have 2 different internal networks with separate dhcp (ran on pfsense) and even split from each other. I've run this setup for around 10+yrs without an issue.

  • I have 1 ISP but 2 connections from the same ISP. They are reliable so failover not an issue.

    2 WAN connections both have seperate IP addresses in entirely different networks. with different Gateways.

    1 is 100Mbps
    2 is 20Mbps(for now)

    I have 5:1 weight assigned to them BUT
    Since both the wans are from SAME isp they each technically get the same dhcp server arp address, which becomes a problem since once one WAN registers the IP and the ARP the other is not able to.

  • Oh ok...so you do have 2 different connections. Are either of those 2 WAN networks the same as your internal network or overlapping? If so that would cause the error your getting. It sucks that your dhcp actually expires. Does your wan IPs actually get a new IP at times? If not, maybe try hard setting the WAN IPs.

  • I try hardsetting the IPs one of them is static but still needs DHCP auth doesnt work with static i tried.

    WAN networks are entirely different than LAN network. And DHCP doesnt really expire but I have no idea why with a lease of 3days 10 mins It keeps refreshing lease every minute.

    The static gets same IP everytime and once this works I will make the other static too.

  • Ok that's some good info. Are you able to get into your ISPs modems/routers? Is there an option to put it into bridge mode or something similar? Maybe their equipment needs to be configured to work properly with pfsense. I know over the years and several different types of modems I had to put it in bridge mode and disable anything firewall related on their devices.

  • The ISP modem is a Huawei Fiber optic, And its bypassed completely the ips are directly assigned to the pfsense. I am trying to talk to ISP to see if this can be solved otherwise there is a solution I just didnt want to add it to the system.

  • Though I still don't understand Why Pfsense is doing this

    Sep 4 14:18:41 dhclient 89787 bound to xxx.xxx.xxx.xxx -- renewal in 60 seconds.

    The lease is 3 days 10 minutes but its refreshing every 60 seconds.

  • Ok it sounds like you are in bypass mode or whatever they have then. Since you are running DHCP it's probably getting all the parameters from them. I haven't looked into dhcp for awhile now...but I know it used to renew (confirm/poll basically) at half the time the lease was set. So if it's renewing that often maybe the ISP has their dhcp lease set too low. I haven't been on the forums for a bit...I couldn't sleep so I came and read some. I'm about to goto sleep finally. I'll come check again in the morning. Hopefully someone else may chime in and assist before then.

  • Yes i think the problem is on ISP trying to get them to fix this.

  • Would multiwan work if both my WAN connections are on the same "subnet"

  • It could work on the same subnet but should be easier to configure and make work with 2 as you have now. I haven't looked at the documentation here for awhile but they do seem to have what you're looking for. Would it be better for you to bond the connections? That could possibly work for you.


Log in to reply