Trouble with NAT (443 works, but other ports don't)



  • I'm having communication issues with my SmartThings hub, research said I need to open up 5 specific ports. I've set up some port forwards, and am able to verify that 443 is open from outside my network. However, all four other ports are showing closed. Here is the rule I have for port 11111:

    98d5fdc4-0017-4b9c-aaaf-b3a19fd46a71-image.png

    It's set up identically to my port forward on port 443. What did I miss? Thanks.



  • @yellowjacketgt
    The destination must not be "any"!
    Select "WAN address" or a virtual IP if applicable.



  • Thanks viragomann. I've updated as you (and the NAT FAQ) suggested:

    2cb2fe36-50fa-4ba3-8981-7291a3dcb5a9-image.png

    The port still shows as closed on https://www.yougetsignal.com/tools/open-ports/. To clarify, 192.168.1.206 is the internal address of my SmartThings hub.



  • Any luck with this, I am new and having a similar problem.


  • LAYER 8 Global Moderator

    So you have pfsense behind a nat as well.. Smarthing hub is a router, so he must have something open in front of pfsense.

    Pfsense can not forward what it never sees.. So anything you want pfsense to forward would have to be set up on whatever is in front of pfsense to forward to pfsense wan IP.

    To be honest step 1 in troubleshooting portfowards, shoot even before you plan on forwarding something is to validate pfsense can see that traffic on its wan.

    Simple to go to can you see me . org and put in the port.. Sniff on pfsense wan while you do the test - do you see the traffic. If not you could spin your wheels on pfsense until your blue in the face, pfsense can not forward what it never sees.

    edit: Oh your the one with same network on both sides of pfsense - so yeah pfsense behind a nat.. So what is in front of your pfsense? You either have to duplicate your port forwards, on the device in front of pfsense, and then again on pfsense. Or you need to put the pfsense wan IP into your edge router dmz host setting.



  • @johnpoz not to hijack this thread, I created a thread for my specific problem. But to answer your question, I have a cable modem router, with the pfSense set as the DMZ.

    https://forum.netgate.com/topic/156840/need-help-creating-my-first-port-forwarding-rule-as-it-doesn-t-work


Log in to reply