After Upgrade API mismatch



  • New to pfsense, purchased a netgate sg-1100, after initial setup through gui, started to upgrade software to the latest. Gui no longer loading and get the following message repeating via console:

    Warning: PHP Startup: session: Unable to initialize module
    Module compiled with module API=0
    PHP    compiled with module API=20170718
    These options need to match
     in Unknown on line 0
    pid 623 (php-cgi), jid 0, uid 0: exited on signal 11 (core dumped)
    Segmentation fault (core dumped)
    

    Assume upgrade did not complete successfully, but am not able to upgrade via the console now and attempts to do anything don't work with this message repeating. Any suggestions would be much appreciated.
    Thanks


  • LAYER 8 Rebel Alliance

    Open a ticket with the Netgate support (free & fast) here: https://go.netgate.com to get the SG-1100 factory Image and reinstall:
    https://docs.netgate.com/pfsense/en/latest/solutions/sg-1100/reinstall-pfsense.html

    -Rico


Log in to reply