• I'm having weird issues in my pfSense install.

    1. It's been aprox. one day of uptime and the server has crashed twice.
    2. The video calls (like Google Hangouts and Zoom) are choppy. The audio and video seems to freeze for about 5 seconds every 10 or 15 seconds.

    I'm load balancing two WANs and I'm also using FQ_Codel. I've done this exact same configuration in many servers and this is the first time that I've had this problem. All the tests were performed using a wired ethernet conection to several computers.

    So far, I've tried connecting directly to both of my internet connections, bypassing pfSense. Connecting directly fixes the error. I've also tried disabling hardware checksum offloading, with no success. I've also disabled FQ_CODEL, disconnected either WAN connection so that no load balancig occurs, also no success.

    The Dell R710 server where pfSense is installed has a warning in the front display, it says "E2110 Multibit Error on DIMM A4, Reseat DIMM". Could this error be related?

    textdump.tar
    info.txt

  • LAYER 8 Rebel Alliance

    So one of your DIMMs is scrap.....YES this will cause all kinds of different problems and errors!

    -Rico


  • Thank you! Indeed, taking out the faulty DIMM fixed all my problems. 😄


  • In the end, the choppy video calls were also caused by EMI over a 40 meter long shielded CAT6 cable for the WAN connection. It went right behind a mini fridge, so I guess that worsened the EMI. I had to set up a fiber link between two switches and send the WAN connection over a separate VLAN on the fiber trunk.