Upgrade stopped part way through due to network dropout



  • Hi, I have an SG-3100 and was upgrading from 2.4.5 to 2.4.5_1 using the WebGUI when the internet dropped out. You can see below the process had made some updates but had just started to download packages.

    Having left it on that page for more than half an hour I went back to the dashboard and started again. It went back in to the upgrade page and instantly jumped back to where it had been, but the download (and overall process) did not resume.

    I don't know if I am stuck half way between versions, and so I am not sure what to do next.

    All help appreciated.

    c>>> Updating repositories metadata... 
    Updating pfSense-core repository catalogue...
    Fetching meta.conf: . done
    Fetching packagesite.txz: . done
    Processing entries: . done
    pfSense-core repository update completed. 10 packages processed.
    Updating pfSense repository catalogue...
    Fetching meta.conf: . done
    Fetching packagesite.txz: .......... done
    Processing entries: .......... done
    pfSense repository update completed. 429 packages processed.
    All repositories are up to date.
    >>> Setting vital flag on pkg... done.
    >>> Removing vital flag from php72... done.
    >>> Downloading upgrade packages... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (13 candidates): .......... done
    Processing candidates (13 candidates): .......... done
    The following 13 package(s) will be affected (of 0 checked):
    
    Installed packages to be UPGRADED:
    	bind-tools: 9.14.9 -> 9.14.12 [pfSense]
    	json-c: 0.13.1_1 -> 0.14 [pfSense]
    	openvpn: 2.4.8 -> 2.4.9 [pfSense]
    	pfSense: 2.4.5 -> 2.4.5_1 [pfSense]
    	pfSense-base: 2.4.5 -> 2.4.5_1 [pfSense-core]
    	pfSense-default-config-serial: 2.4.5 -> 2.4.5_1 [pfSense-core]
    	pfSense-kernel-pfSense-SG-3100: 2.4.5 -> 2.4.5_1 [pfSense-core]
    	pfSense-rc: 2.4.5 -> 2.4.5_1 [pfSense-core]
    	pfSense-u-boot-sg3100: 2.4.5 -> 2.4.5_1 [pfSense-core]
    	python37: 3.7.6 -> 3.7.7 [pfSense]
    	sshguard: 2.4.0_3,1 -> 2.4.0_4,1 [pfSense]
    	strongswan: 5.8.2 -> 5.8.4 [pfSense]
    	unbound: 1.9.6 -> 1.10.1 [pfSense]
    
    Number of packages to be upgraded: 13
    
    The process will require 8 MiB more space.
    63 MiB to be downloaded.
    [1/13] Fetching unbound-1.10.1.txz: .......
    
    


  • @PaulRAU said in Upgrade stopped part way through due to network dropout:

    SG-3100

    I'm almost certain you will need an image from Netgate. You open a ticket and they will provide that very quickly. You will then burn that to a usb stick and install the image over the top of what you have and all should be good.

    Repost this in the Netgate hardware sub-forum to get someones attention faster.

    @stephenw10


Log in to reply