Problems with squid on friendster



  • installed my pfsense on p4, 512mb memory, also added squid package yesterday…

    all went well, tested squid caching with no problems at all with some websites

    but when i deployed my pfsense machine on the network just now, i was horrified that users reportedly
    cannot log-in to their friendster account, although i browsed a few sites (hereby caching some of them)
    including friendster, it works ok but i did not log-in to friendster at the time...so I tested the friendster
    log-in problem, after entering username + password on friendster and then clicking the login button
    the profile page doesnt load...or it seems to load slowly, where as i tested without the squid cache
    it doesnt have any problems, i know this is a bug in squid, have the same windows version of squid
    and it also have the same problem, is there a workaround for this? before i deployed squid on my server
    machine using ramdrive for the cache, im very happy that upon installing pfsense, there is also a squid
    package, and i would really like to have squid on the pfsense machine (offloading the server)...

    im currently using the latest stable version of pfsense (not the rc release)

    recap, the problem is by using squid, users cannot login to friendster, is there a solution/workaround for this? also already searched for a possible solution for this, but i did not find one...

    thanks for the help...



  • If your using squid from pfsense package and using default configuration then probably the kern.ipc.nmbclusters is zero.

    runsysctl kern.ipc.nmbclustersand if zero then set```
    sysctl kern.ipc.nmbclusters=8192

    
    I've encounter this kind of issues before when caching dynamic contents like URL contents with ? Most servers like friendster have no Cache-Control header on thier index.php(but i think its fixed already). So i have added to my squid.conf refresh_pattern \.php 0 0% 0 as a result this will not cache all URL the has .php

Log in to reply